Generate OpenAccess Domain Model Service

4 posts, 0 answers
  1. CG
    CG avatar
    6 posts
    Member since:
    Jan 2006

    Posted 16 Mar 2012 Link to this post

    No matter what I do I just can't get my domain model to list in the Select context: drop down when selecting your source and output from the first screen after selecting "Generate OpenAccess Domain Model Service" from the right click of my rlinq file.

    I've completed a successful build.

    2 questions.

    1) Is there a difference between "Generate OpenAccess Domain Model Service" and the results of running the Data Services Wizard?
    2) What more can I try to get the Generate OpenAccess Domain Model Service process to work?

    My domain model is in a class library.
  2. Ian
    Ian avatar
    26 posts
    Member since:
    Jun 2012

    Posted 20 Mar 2012 Link to this post

    I've had trouble with the generation of domain models, etc too.  There seems to be an old way and a newer way.  The issue where it wouldn't appear in the dropdown is due to some caching going on (I opened a support ticket).  Restarting VS seemed to fix the issue at the time.

    Having said that, I've been away from developing for a few weeks and haven't tried the new OA version yet (it's installed though).  I'm on the forums just before I get back into development precisely to see what's changed, broken, interesting, etc :)  If I manage to get VS to load my solution  (RadControls WPF updater seems to freezing the solution loading) and find something in this area I'll let you know.
  3. DevCraft banner
  4. Viktor Zhivkov
    Viktor Zhivkov avatar
    290 posts

    Posted 20 Mar 2012 Link to this post


    You both have stumbled upon a known issue that has been fixed in the latest release (from the beginning of March) - Q1 2012 SP1. The best way to resolve it is to update OpenAccess ORM to the latest version.

    I am looking forward to your feedback if you have any more troubles with it.

    Thank you for your time and  interest in OpenAccess.


    Viktor Zhivkov
    the Telerik team
    Telerik OpenAccess ORM Q1 2012 release is here! Check out what's new or download a free trial >>
  5. CG
    CG avatar
    6 posts
    Member since:
    Jan 2006

    Posted 20 Mar 2012 Link to this post

    Thank you Viktor!

    I've upgraded and it now works.
Back to Top