Forum search functionality currently not working

7 posts, 0 answers
  1. Polaris431
    Polaris431 avatar
    30 posts
    Member since:
    Jul 2007

    Posted 21 Jan 2009 Link to this post

    I just went to the Forum that covers the Toolbar and did a search using the keyword "event" and no results came back, yet there are postings with the word "event" in the title. I tried other words that should have generated some results but any query I enter yields no results. Please check your server application that handles searching.
  2. Paul
    Admin
    Paul avatar
    4281 posts

    Posted 22 Jan 2009 Link to this post

    Hi Polaris431,

    We made a similar search we got proper results. See attached screenshot. Am I missing something?

    Sincerely yours,
    Paul
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. SonicImaging
    SonicImaging avatar
    88 posts
    Member since:
    Jan 2007

    Posted 25 Jan 2009 Link to this post

    Actually this happens quite often, for all searches,  demo's, forums and docs,  if I do the same search on the chm file then it finds but I prefer to do the searching online within the telerik site.

    For example,  search on card view in the docs,    click the first result which will bring you to the card view docs.  If you click on the online demo link you'll get the sorry we couldn't find the page your looking for.  then search in the demo's for card view or even cardview there are no results,   yet card view is here http://demos.telerik.com/aspnet-ajax/Grid/Examples/GeneralFeatures/CardView/DefaultCS.aspx

    It seems like its the search mechanism that has troubles cause sometimes it works perfectly and others not at all.  I also see a lot of server errors when searching.

    Also its very slow,  takes 10-15 seconds per search.

    Thanks
    -Keith




  5. Steve Y
    Steve Y avatar
    115 posts
    Member since:
    Sep 2008

    Posted 25 Jan 2009 Link to this post

    I've seen odd results while searching and have come to the conclusion that searching is not always reliable - which is bad, right? Perhaps it's just my expectation but I do expect that the title and the body of each post will be searched. I also kinda expect that the results will be delivered in descending date within best match. e.g. if I search for three words, then all posts that contain those three words will be shown first and in descending date order, then all two word matches in descending date order, etc. Is that the case? If not, perhaps the search capability needs to be explained...

    As an example of where it did not work according to my expectations was searching for this post you're reading right now... I did a search in this forum ( RadControls for ASP.NET AJAX: General Discussions) and my search was for the title of this post (Forum search functionality) and this post was not found which was odd to me because this post was #1 in the forum list at that time. Now, maybe the titles are not part of the search criteria but, if that's the case, I believe it should be changed to include words in the title. If titles are part of the search then there's something wrong as it did not find this post.

    Telerik. What am I doing wrong? Or are my expectations out of whack with the actual search capability?

    Regards, Steve
  6. SonicImaging
    SonicImaging avatar
    88 posts
    Member since:
    Jan 2007

    Posted 28 Jan 2009 Link to this post

    Also it would be great if the search in the demo's would only search on the current products demo.  Currently the search is site wise so you have to weed through all of the products.

    Thx
    -Keith
  7. Kaloyan Simeonov
    Admin
    Kaloyan Simeonov avatar
    5 posts

    Posted 29 Jan 2009 Link to this post

    Keith, you are right. The link we have provided in this article is wrong. It should be http://demos.telerik.com/aspnet-ajax/grid/examples/generalfeatures/cardview/defaultcs.aspx. It has nothing to do with the search resutls or relevance, and we will fix it ASAP. Can you provide us whith the search queries which you have troubles with? It will be easier for us to reproduce the problem.

    We will consider the possibility for the demo search, to provide results for the current suite (Product Line) only.

    Steven, you will help us if you provide me with some other search query you have found strange or irrelevant. We use google search appliance for our site searches, and the relevance and order of the results should be the same like in google.com.

    Sometimes it takes some time for the crawler to find the new resources. In this case 8 days seem too much, so we will investigate the issue and will react accordingly.

    Thank you for your feedback!

    Best,
    Kaloyan Simeonov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  8. SonicImaging
    SonicImaging avatar
    88 posts
    Member since:
    Jan 2007

    Posted 29 Jan 2009 Link to this post

    Thank for the reply,    Ive got a few days of work to do with the controls so ill keep a list of any issues I run into with the searches.  Ill also keep track if a search didn't work then later worked.  Which seems to happen to me more often then never working.  I know Ive searched on something with no results then later searched on the same term and results were found.   I keep an eye on that also.

    Here is a quick one I just found... This is interesting.  I posted a sort question in the radgrid forum and I just thought I might need to remove all the sort expressions before adding a new one so I want to look at RemoveSortExpression.  This is what I tried.

    1) Go here http://www.telerik.com/help/aspnet-ajax/introduction.html
    2) search on RemoveSortExpression
      You'll get the correct results

    Then go to google and search on RemoveSortExpression radgrid ajax

    The first result in google should take you to the same ajax docs but inside the docs
    http://www.telerik.com/help/aspnet-ajax/grdsortingexpressions.html

    Now search on RemoveSortExpression

    you'll get Your search RemoveSortExpression did not match any documents.

    if you click repeat search in all radcontrols you get results

    I think this might be why it seems to me to be random,  but I think it depends on how you enter the docs

    Hope This helps
    -Keith
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017