Foreign chars, strange behavior

4 posts, 1 answers
  1. Oscar
    Oscar avatar
    21 posts
    Member since:
    Sep 2008

    Posted 08 Apr 2010 Link to this post

    Hello
    In an aspx project, I have two (very similar) pages that use a number of Telerik controls.
    In both pages foreign chars like ó, é   (vowels with tilde) are directy types for example in labels, and some other places
    However, in one of the pages these characters display ok, in the other page they display as square boxes.

    I am not using resource files, and cannot find any significant differences in the encoding, neither in aspx or aspx.vb files. Both pages use the same master page.
    I attach the screenshots (screenok, screenbad) and the respective code (codeok, codebad).

    Of course if I use HTML encoding (ó instead of ó) they show ok in every case, but it is a real pain...
    What am I missing?

    TIA
  2. Oscar
    Oscar avatar
    21 posts
    Member since:
    Sep 2008

    Posted 08 Apr 2010 Link to this post

    I mean  foreign chars like ó, é   (vowels with tilde) are directy typed from the keyboard using the VS IDE
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Answer
    T. Tsonev
    Admin
    T. Tsonev avatar
    2770 posts

    Posted 08 Apr 2010 Link to this post

    Hi Oscar,

    Please, make sure that you're saving the files as Unicode - UTF-8 with signature from File -> Advanced Save Options in VS. If this doesn't help try adding a meta tag:

    <meta http-equiv="content-type" content="text/html; charset=utf-8" />

    I hope this helps.

    Sincerely yours,
    Tsvetomir Tsonev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Oscar
    Oscar avatar
    21 posts
    Member since:
    Sep 2008

    Posted 11 Apr 2010 Link to this post

    Thanks, Advanced Save Options did the trick, as a backup mechanism I added the HTTP-Equiv tag to my master page.
    Regards
Back to Top