Force to rearrange measurement of Y axis value range

3 posts, 0 answers
  1. Robin
    Robin avatar
    19 posts
    Member since:
    Feb 2011

    Posted 21 Nov 2013 Link to this post


    I got a problem with the automatic measurement of the main Y axis label range. The corresponding dataseries is created completly in code behind.
    So when the data is being visualized the actual range of the Y axis is not correct (see attached image). But when I manually change the size of the window and recalculating of measurements begins the Y axis updates and the range fits perfectly just as expected (second image).

    So is there an API method to force the chart to recalculate the min, max value and step of the Y axis?

    Thanks for your help!
  2. Peshito
    Peshito avatar
    493 posts

    Posted 25 Nov 2013 Link to this post

    Hi Robin,

    I tried to reproduce the issue you have but to no avail. I have also noticed you have opened another ticket thread regarding the same. I would suggest to keep the conversation in one thread so it is easier for both sides to follow. Regarding the issue, in order for us to give you an appropriate answer, could you please attach a sample project reproducing the issue. You can either modify the project I am attaching to this thread or give us a runnable copy of yours.

    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  3. DevCraft R3 2016 release webinar banner
  4. Robin
    Robin avatar
    19 posts
    Member since:
    Feb 2011

    Posted 26 Nov 2013 Link to this post

    I found a fix for the issue. The problem was that I always initiated a new instance of the main Y axis when reloading data.
    When using the default instance everything works fine.
Back to Top