Fonts in simulator and debugger are rendered poorly

18 posts, 0 answers
  1. Bill
    Bill avatar
    9 posts
    Member since:
    Jul 2013

    Posted 30 Jul 2013 Link to this post

    The fonts in my simulator for both iOS and Android look like they are being rendered from a 2 point font. I've attached a screen shot.

    I'm running on Windows 8.

  2. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 31 Jul 2013 Link to this post

    Hi Bill,

    We have not been able to reproduce this in our local tests and would appreciate if you provide more information:
    • are you using the latest drivers for your video card? Please go to the manufacturer's website and update the drivers if necessary.
    • does this occur only for the Icenium Simulator?
    • have you customized/changed any of the default Windows fonts? If so can you try reverting to the default theme and verify whether the problem still exists?
    • are there any errors in the Windows event logs that could be related (involve Graphite)?

    Any additional information you consider relevant would be highly appreciated.

    Regards,
    Steve
    Telerik

    Do you enjoy Icenium? Vote for it as your favorite new product here (use short code H048S).
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  3. Bill
    Bill avatar
    9 posts
    Member since:
    Jul 2013

    Posted 01 Aug 2013 Link to this post

    This is running on an HP laptop with an nVidia Quadro graphics chip. I downloaded the latest from HP and when that didn't fix the problem I got the most recent recommended driver from nVidia. This also didn't work.

    The problem only occurs in the simulator but it is both in the simulated screen and the debugger.

    I haven't changed the default fonts, this is a fairly fresh install of Windows 8.

    I didn't see any Icenium related errors in the event viewer. 

    I am running Icenium on my desktop as well and don't see the issue. I'll try uninstalling and reinstalling to see if that solves the problem.
  4. Scott
    Scott avatar
    16 posts
    Member since:
    Dec 2007

    Posted 07 Sep 2013 Link to this post

    I too am running Windows 8 on a newer HP with an nVidia and having the same problem.  I also notice in the main IDE some of the icons in the UI have jagged edges as well, not really a problem but all the jaggies in the simulator is really annoying.
  5. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 09 Sep 2013 Link to this post

    Hello Scott,

    Should we assume you have tried the suggestions from our previous reply and none help? Did re-install of Graphite had any effect?

    Regards,
    Steve
    Telerik

    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  6. Scott
    Scott avatar
    16 posts
    Member since:
    Dec 2007

    Posted 09 Sep 2013 Link to this post

    I'm running the latest driver for my GeForce 630M which is 320.49.  I also tried re-installing but no change.  It actually also happens in the main IDE as well it's just not very noticeable because it doesn't occur in the editors, but if you look at the some of the icons like close or help you can see it.  Let me know if you want more information regarding my system.
  7. Scott
    Scott avatar
    16 posts
    Member since:
    Dec 2007

    Posted 09 Sep 2013 Link to this post

    Also I don't find anything regarding Icenium in the logs.
  8. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 10 Sep 2013 Link to this post

    Hi guys,

    We were able to reproduce the problem with increased DPI (different than 100%) in the windows display settings (Control Panel\All Control Panel Items\Display). We've logged the issue to our bug tracking system for investigation and fix.

    Thanks for the involvement and understanding!

    Regards,
    Steve
    Telerik

    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  9. Scott
    Scott avatar
    16 posts
    Member since:
    Dec 2007

    Posted 10 Sep 2013 Link to this post

    Turns out my display was set to 125% and setting it to 100% fixes the issue, but I look forward to a fix since the display is a little smaller than I like.
  10. Bill
    Bill avatar
    75 posts
    Member since:
    Feb 2013

    Posted 03 Jul 2014 Link to this post

    I also have this problem.  The proposed fix to set your display text setting to 100% (default) does not apply as it was already set to such.  See my screenshot.  Text is all pixelated.
  11. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 07 Jul 2014 Link to this post

    Hi Bill,

    We have seen some strange behavior of the Simulator when used on HP machine even with the latest graphic drivers.
    However the only way to reproduce this crispy view is when changing the zoom state of the Simulator.

    We will try to reproduce your issue, but we will need some details about your font (family, size etc.). Additionally we will be very grateful if you isolate this issue in a sample project and send it to us so we can have a starting point.
    Thanks.

    Regards,
    Zdravko
    Telerik
     

    Share what you think about AppBuilder and Telerik Platform with us in our feedback portal, so we can become even better!

     
  12. Bill
    Bill avatar
    75 posts
    Member since:
    Feb 2013

    Posted 07 Jul 2014 in reply to Zdravko Link to this post

    Here are some of my details:

    - Dell Latitude E6530 Laptop w/ Nvidia NVS 5200M video card.
    - I've updated my graphic drivers to the latest
    - The zoom state is at 100% - I experience the issue regardless of what zoom I set
    - I'm using the Kendo Mobile Flat Theme v2014.1.318 which uses Arial

    I don't see the issue on some of the core sample projects.  So my guess it has something to do with a style that Kendo is applying to things.
  13. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 10 Jul 2014 Link to this post

    Hello Bill,

    Thanks for your details.
    Unfortunately we don't have similar laptop, but after I tried to reproduce your issue on my workstation using Flat theme I found that the app is looking even better. I was using Kendo UI template we provide and as you can see in this screenshot it is looking crispy by default. This might be a limitation of our Simulator as it is not behaving like actual emulator. The most important is that it will look fine on device and will not affect users' experience.
    If you doubt about any visualization in the Simulator and for best testing experience I recommend using a real device. This way you can be a 100% sure about the final view.

    We will continue to keep an eye over this glitch and try to solve it.
    Thanks and stay tuned.

    Regards,
    Zdravko
    Telerik
     

    Share what you think about AppBuilder and Telerik Platform with us in our feedback portal, so we can become even better!

     
  14. Bill
    Bill avatar
    75 posts
    Member since:
    Feb 2013

    Posted 10 Jul 2014 in reply to Zdravko Link to this post

    What has changed recently to cause the poor rendering in the simulator?  It used to be fine but after a recent update it went south.

    Yes, everything looks great when it is ran on a real device.  What's strange is other samples run and look fine, however the kendo UI flat theme is messed up for me in the simulator.  I'll keep watch for potential fixes.  
  15. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 15 Jul 2014 Link to this post

    Hello Bill,

    I am not aware of any purposely made changes in this direction. We will keep an eye over this case and try to make improvements.
    Thanks.

    Regards,
    Zdravko
    Telerik
     

    Share what you think about AppBuilder and Telerik Platform with us in our feedback portal, so we can become even better!

     
  16. JohnVS
    JohnVS avatar
    76 posts
    Member since:
    Apr 2013

    Posted 12 Aug 2014 in reply to Zdravko Link to this post

    I have noticed that the problem with AppBuilder and the Kendo Flat theme stylesheet seems to be caused primarily by the font-family it uses. This style sets the overall font-family for the Flat theme here:

    .km-flat { font: normal 1em "HelveticaNeue Light","Roboto Light","Slate Light","Segoe WP",NokiaPureTextLight,sans-serif; }

    If you replace this style with:

    .km-flat { font: normal 1em Arial; }

    Suddenly, the font looks perfectly fine in the Simulator.

    I know there has been a problem with the Chrome browser and Google Web Fonts for a long time (see https://code.google.com/p/chromium/issues/detail?id=137692 for the details). Could this problem with Chrome also possibly be the cause of the badly rendered text in the Simulator?
  17. JohnVS
    JohnVS avatar
    76 posts
    Member since:
    Apr 2013

    Posted 12 Aug 2014 in reply to JohnVS Link to this post

    (here is a screenshot of the difference when changing the default font for the Flat theme)
  18. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 15 Aug 2014 Link to this post

    Hi John,

    Thanks for sharing your finding with our community.
    Indeed this font improves the view in the Simulator and provides better feeling. I do believe this is related to the CEF we are using in our Simulator and we will try to improve it if possible.
    However the main idea of the Simulator is to provide a quick view of any changes made in the app and some glitches are expected because of the different browsers that every platform uses.
    For ultimate testing we recommend using a real device or emulator where you can be sure for the outcome at users' side.


    Regards,
    Zdravko
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
Back to Top