Font name and size drop-downs do not reflect changed font name or size

3 posts, 0 answers
  1. Steve
    Steve avatar
    24 posts
    Member since:
    Jun 2010

    Posted 19 Aug 2014 Link to this post

    I have seen some similar posts, but they do not describe the exact problem I'm facing.

    This behavior can easily be seen in the demo at: http://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx

    Double-click on a word within the editor window.  Notice the font name and size dropdowns are updated to reflect the highlighted word's font and size.

    Now, select a new font from the dropdown.  For example, let's say you highlighted a word with Arial font.  Now select Verdana from the dropdown.  Notice that the actual text in the editor changes to Verdana, but the font name dropdown still says Arial.  This behavior is the same for the font size dropdown.

    It seems that the font name and size dropdowns are always one step behind what is actually happening, because if you now click the font name dropdown and change the font again to Georgia, the text will change to Georgia, but the font name dropdown now says Verdana.

    I am seeing this same behavior in our own website and customers are complaining.

    Any ideas?  Thanks for your time.
  2. Nikolay
    Admin
    Nikolay avatar
    64 posts

    Posted 21 Aug 2014 Link to this post

    Hi,

    Thank you for reporting this issue. I reproduced it in Internet Explorer 9, 10, 11. It looks like the selected element is not correct.

    I have logged the issue into our feedback portal. You can check its status, workaround, vote and comment it here.

    Regards,
    Nikolay
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Steve
    Steve avatar
    24 posts
    Member since:
    Jun 2010

    Posted 21 Aug 2014 in reply to Nikolay Link to this post

    Thanks for the reply.  I will try the workaround.
Back to Top