Flash embed works on only top level publishing site in site collection

6 posts, 1 answers
  1. Christian Ecker
    Christian  Ecker avatar
    3 posts
    Member since:
    Mar 2010

    Posted 17 Mar 2010 Link to this post

    Hi,

    I've installed the RadEditor and the MOSS 2007 integration, modified the RadEditorFeatureRichHtml and RadEditorFeatureRichText to Site level scope, and my content editing boxes are automatically replaced with RadEditor.  This is great, as I can now edit in FireFox, Chrome, etc.!  However, I'm running into a strange problem.

    I want to embed Flash videos, a la YouTube embeds.  I use the HTML view, and switching back and forth between that and the design view indicates that there is no problem with the browser stripping the tag.  When I submit the content, though, it seems the embed tags and/or object tags disappear.  What's weird is that on my top-level page, it seems to work just fine-- I can copy a YouTube embed link, paste it into the RadEditor, click publish, and it will show up in the published view.  I need it to work on all the sites, though, and I can't seem to figure out what is special about the top-level site.

    I understand that SharePoint has some server-side processing to remove embed and object tags.  I have seen mention, from the forums, that there was a possibility of encoding those tags before submission and automatically decoding them at retrieval in order to bypass this.  Does RadEditor implement this?  If not, where does the server-side filtering occur, and how does it get bypassed?

    All the content columns in question are of type Publishing HTML.  Please advise if I need to give more information.

    Thanks!
  2. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 17 Mar 2010 Link to this post

    Hello Christian Ecker,

    Review the following online help article Scripts in RadEditor. Enabling special tags is the same as enabling scripts.


    Regards,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.

  3. Christian Ecker
    Christian  Ecker avatar
    3 posts
    Member since:
    Mar 2010

    Posted 17 Mar 2010 Link to this post

    Thanks for your quick response, Stanimir.  I've added properties AllowScripts and AllowSpecialTags with value true to both ConfigFile.xml and ListConfigFile.xml and done an iisreset.  The issue remains.  Please be aware that our site has been developed using Visual Studio, so the Sharepoint Designer route is somewhat closed to us.

    Have you any more ideas about how I could investigate?  Why does it work on one page and not others?

    cheers

  4. Answer
    Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 18 Mar 2010 Link to this post

    Hello Christian ,

    Here is some additional information.

    1. Webpart scenario: what you need to do is modify the respective ConfigFile.xml, which is located in the /Program Files/Common Files/Microsoft Shared/web server extensions/wpresources/RadEditorSharePoint/5.x.x.0__1f131a624888eeed/Resources/ folder and add the following line:
    <property name="AllowScripts">true</property>

    2. WCM scenario: If you want to enable special tags in this scenario, you need to replace the original PublishingWebControls:RichHtmlField with telerik:RadHtmlField, as it is described in http://www.telerik.com/help/aspnet-ajax/using-radeditor-in-web-content-management-scenario.html help article, and set these properties: AllowSpecialTags="true" AllowScripts="true"
    For example:
    <telerik:RadHtmlField id="Content" FieldName="PublishingPageContent" AllowSpecialTags="true" AllowScripts="true" runat="server"></telerik:RadHtmlField>

    3. In list scenario (list, wiki, blog ...) all special tags will be stripped, when the content is saved. So you can not insert object or any kind of special tags.
     

    All the best,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Christian Ecker
    Christian  Ecker avatar
    3 posts
    Member since:
    Mar 2010

    Posted 24 Mar 2010 Link to this post

    Stanimir,

    Replacing the tags in the publishing page layouts does indeed cause the content to persist in an encoded state.  It doesn't explain why I _don't_ need to do this on the top-level page, but since it seems to be working, we are able to ignore that anomaly for now.

    The only other question: I want to display the decoded message in a separate field, which was a Microsoft.SharePoint.Publishing.WebControls.FieldValue but that outputs the pre tag still encoded and invisible.  Is there a tag which will decode the content but not switch to edit mode? (since I have a separate edit panel, it is unsightly and confusing)

    I found the code here: http://www.telerik.com/community/forums/sharepoint-2007/full-featured-editor/problems-adding-media.aspx#465317   so I can create a control myself to do this.  My question is if there is a more modern supported method for doing this?

    cheers
  6. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 25 Mar 2010 Link to this post

    Hello Christian Ecker,

    You can use the following static methods.
    1. Telerik.SharePoint.EditorTools.UnEscapeSpecialTags(string html) - this will encode the content before saving it.
    2. Telerik.SharePoint.EditorTools.EscapeSpecialTags(string html) - this will decode the content before displaying it.

    I hope this helps.

    Greetings,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top