First hover of unpinned sliding pane does not cause fly-out of the pane

2 posts, 0 answers
  1. Adam
    Adam avatar
    70 posts
    Member since:
    Jun 2008

    Posted 28 May 2009 Link to this post

    Hi everyone,

    We have a small UI issue with the RadSplitter.  The set up consists of two Rad Panes, left and right, the left pane containing a RadSlidingZone and a RadSlidingPane.  By default, the left pane is pinned, but after unpinning the pane, hovering over the sliding zone tab once does not cause the pane to slide out.  Moving the cursor off of the tab and back onto the tab a second time causes the pane to fly out and any subsequent pin/unpin works as intended.

    Obviously, this behavior is unintended, and though simple, can be frustrating for users.

    Thanks a lot for the help,

  2. Svetlina Anati
    Svetlina Anati avatar
    2795 posts

    Posted 30 May 2009 Link to this post

    Hello Adam,

    I am not quite sure about your exact setup and configuration and when and how you dock the RadSlidingPane. Without examining your code I could think of three scenarios:

    1. You have set the RadSlidingPane to be initially docked when the page gets loaded by setting the DockedPaneID property.
    2. You have docked the RadSlidingPane on expand by using javascript.
    3. You have used a combination of the above two setups.

    I tested all the 3 scenarios but I was not able to reproduce the problem and everything works fine. Would you please examine the attached demo and let me know what I am missing? Once I have a better understanding on what is causing the issue on your side, I will do my best to help.

    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. DevCraft R3 2016 release webinar banner
Back to Top