FileTransfer sample not showing the image

4 posts, 0 answers
  1. Sepehr
    Sepehr avatar
    14 posts
    Member since:
    Oct 2014

    Posted 19 Nov 2014 Link to this post

    Hi There,

    I'm testing the file transfer demo in simulator with AppBuilder windows client. It wonderfully downloads the image but cannot show it. I checked the network requests and you can see the result in attached files. Any idea buddies?


    Cheers,
    Sep
  2. Sepehr
    Sepehr avatar
    14 posts
    Member since:
    Oct 2014

    Posted 20 Nov 2014 Link to this post

    Hi again guys,

    I guess, in some how I need to configure the simulator to run the chrome with these two flags:

    –allow-file-access-from-files
    –disable-web-security

    But I have no idea where I can apply these settings :D

  3. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 21 Nov 2014 Link to this post

    Hello Sep,

    This is a known issue in the device simulator but we are currently not aware of a workaround. We will do our best to address it in a timely manner but I cannot yet commit to a specific time frame.

    Please accept my apology for this inconvenience.

    Regards,
    Tina Stancheva
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  4. Sepehr
    Sepehr avatar
    14 posts
    Member since:
    Oct 2014

    Posted 23 Nov 2014 Link to this post

    Hi Tina,

    Thank you very much for your answer. I appropriate it.

    Fortunately it works fine on actual device and emulators so it's not something critical. And also for developers like me who prefer to work with simulator, we can set two variables for write path and for read path, and for the read path we can set a local website using IIS and show the file through it while developing.

    Cheers,
Back to Top