fiddler web debug.has "tools->HOSTS" function ,where it in fiddlercore?

3 posts, 0 answers
  1. poko
    poko avatar
    4 posts
    Member since:
    Aug 2014

    Posted 01 Aug 2014 Link to this post

    sorry ,i am chinese.English is very poor .

    i see fiddler web debug have a function named "HOSTS",it in catalog "tools->HOSTS",

    now i use fiddlercore,but i donot find the HOSTS function .

    i found  a class named HostList,but I don't know how to use it.

    i want   modify request host's ip address.

    for example :
      private void onBeforeRequest(Fiddler.Session oSession)
                //now = "";ip is,i want modiyf to ,but the request head remain the same

               // under code is not working, I don't know whether or not write code in beforeRequest or other place
               oSession.m_hostIP = "";

              //under code is modefiy request head
              // = "";


    thank you make the fiddler software.  Help me to solve a lot of trouble.

  2. Eric Lawrence
    Eric Lawrence avatar
    833 posts

    Posted 01 Aug 2014 Link to this post


    This topic is covered in the Fiddler Book ( which was given to a Chinese company to translate; I don't know if the Chinese version is out yet.

    To retarget a request, set the X-OverrideHostName flag on the Session. You may also wish to add an X-IgnoreCertCNMismatch flag if the request is HTTPS.

    For instance: 

    if (oSession.HTTPMethodIs("CONNECT") && oSession.HostnameIs(""))
    oSession["X-OverrideHostName"] = "";
    // Set flag to suppress Fiddler's HTTPS Name Mismatch errors
    oSession["X-IgnoreCertCNMismatch"] = "no worries mate";


    Eric Lawrence

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

  3. poko
    poko avatar
    4 posts
    Member since:
    Aug 2014

    Posted 01 Aug 2014 in reply to Eric Lawrence Link to this post

    thanks again,it is working now.  that  puzzled me for a long time.

    i could not return,only say thank you .you are a good man. 
Back to Top