Fiddler not capturing IE requests only for intranet

8 posts, 0 answers
  1. Rekna
    Rekna avatar
    5 posts
    Member since:
    Apr 2011

    Posted 06 Jan Link to this post

    Fiddler is capturing all internet requests from internet explorer, but as soon as I request something internally (site hosted in iis on my pc or site hosted in iis on server in our domain), fiddler does not show anything.

    When I use chrome, all traffic shows up (intranet and internet), no problem there. 

    But I need fiddler for some internet explorer specific problem, so does anyone have any idea why fiddler is not capturing requests from IE for intranet sites?

  2. Tsviatko Yovtchev
    Admin
    Tsviatko Yovtchev avatar
    409 posts

    Posted 08 Jan Link to this post

    Hi,

    Do you have any active filters? Have you tried switching all filters off? You can also check out the Log tab for clues.

    Also, what shows up in IE and chrome when accessing http://127.0.0.1:8888 and http://localhost.fiddler:8888 ? Is there any difference?

    Regards,
    Tsviatko Yovtchev
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Rekna
    Rekna avatar
    5 posts
    Member since:
    Apr 2011

    Posted 13 Jan in reply to Tsviatko Yovtchev Link to this post

    I do not have any active filters.  The checkbox Use Filters is not checked.

    Responses are the same:

    -----------------------------------------------------------------------------------------------------------------------------

    GET / HTTP/1.1
    Accept: text/html, application/xhtml+xml, */*
    Accept-Language: nl-BE,nl;q=0.5
    User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko
    Accept-Encoding: gzip, deflate
    Host: 127.0.0.1:8888
    DNT: 1
    Connection: Keep-Alive


    This page returned a HTTP/200 response 
    Originating Process Information: iexplore:7888

    ----------------------------------------------------------------------------------------

    GET / HTTP/1.1
    Accept: text/html, application/xhtml+xml, */*
    Accept-Language: nl-BE,nl;q=0.5
    User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko
    Accept-Encoding: gzip, deflate
    Host: localhost:8888
    DNT: 1
    Proxy-Connection: Keep-Alive


    This page returned a HTTP/200 response 
    Originating Process Information: iexplore:7488

    -------------------------------------------------------------------------------

    GET / HTTP/1.1
    Host: 127.0.0.1:8888
    Proxy-Connection: keep-alive
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
    Upgrade-Insecure-Requests: 1
    User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36
    Accept-Encoding: gzip, deflate, sdch
    Accept-Language: nl,en-US;q=0.8,en;q=0.6

    This page returned a HTTP/200 response 
    Originating Process Information: chrome:7016

    -------------------------------------------------------------------------------

    GET / HTTP/1.1
    Host: localhost:8888
    Proxy-Connection: keep-alive
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
    Upgrade-Insecure-Requests: 1
    User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36
    Accept-Encoding: gzip, deflate, sdch
    Accept-Language: nl,en-US;q=0.8,en;q=0.6

    This page returned a HTTP/200 response 
    Originating Process Information: chrome:7016

     

  4. Rekna
    Rekna avatar
    5 posts
    Member since:
    Apr 2011

    Posted 14 Jan in reply to Rekna Link to this post

    It seems to be working again... I tried Help / Troubleshoot, and it started showing my requests... 
    Troubleshoot normally displays all filtered request using a striketrough font, but none of my requests were displayed using stikethrough font, so Troubleshoot must have reset something, but it's unclear what this might be.

    I restarted Fiddler and it continues to show all my requests.. So it seems to be solved.

  5. Rekna
    Rekna avatar
    5 posts
    Member since:
    Apr 2011

    Posted 14 Jan in reply to Rekna Link to this post

    Unfortunately, it stopped again... this is really weird.  Trying Help/Troubleshoot does not show any of my requests, so it's not a filter.
  6. EricLaw
    EricLaw avatar
    67 posts
    Member since:
    Oct 2012

    Posted 30 Jan in reply to Rekna Link to this post

    The Troubleshoot option makes no configuration changes; it simply unhides hidden requests.

    The most likely explanation for the behavior described is that there's some other software on your PC (e.g. RAS/VPN, DirectAccess, or similar) that is changing the behavior of network requests in IE.

    You should confirm that the box on Tools > Fiddler Options > Connections contains only <-loopback>

  7. Rekna
    Rekna avatar
    5 posts
    Member since:
    Apr 2011

    Posted 01 Feb in reply to EricLaw Link to this post

    intranet sites (which don't log in fiddler) = DirectAccess, IPV6

    Fiddler IPV6 option is enabled.

    Our IT guy asked if Fiddler is fully ipv6 compliant? Thinks it has to do something with IPV6...

  8. EricLaw
    EricLaw avatar
    67 posts
    Member since:
    Oct 2012

    Posted 04 Feb in reply to Rekna Link to this post

    Fiddler is fully IPv6 compliant.

    DirectAccess is a different story. DirectAccess is a hack inside the Windows network stacks (WinINET/WinHTTP) that causes traffic to bypass the configured proxy for the sites known to DirectAccess. There's no simple workaround for this; the typical approach is to just VPN/RAS into the corporate network (e.g. remote desktop to a PC inside the org) and run Fiddler there such that DirectAccess doesn't interfere with anything.

Back to Top