Fiddler keeps capturing traffic when capturing was stopped

4 posts, 0 answers
  1. Max
    Max avatar
    2 posts
    Member since:
    Mar 2014

    Posted 24 Mar 2014 Link to this post

    Environment: Fiddler 4.4.6.2 64-bit on Windows 8
    Proxy server in the browser was manually set to localhost:8888.

    Problem: when Fiddler is told to NOT capture traffic (the icon in the left bottom corner disappears) Fiddler still captures traffic and displays it.

    Basically there is no way to temporarily disable capturing other than disabling proxy in the browser. This is very inconvenient, especially in a VM environment.
  2. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 24 Mar 2014 Link to this post

    Hi, Max--

    I'm not really sure I understand the issue you're reporting. What browser are you using? Why would you manually adjust the browser's proxy rather than letting Fiddler handle it?

    Fiddler's "Capturing" setting (File > Capture Traffic, or click in the status bar) concerns whether Fiddler is registered as the system proxy. That setting obviously has no way to prevent a client from manually directing its traffic to Fiddler. If you really wanted, you could use an AutoResponder rule to force all traffic sent to Fiddler while "capturing" is off to fail, but this would probably break your applications and it's really not clear how this would be of any benefit.

    If, for whatever reason, you want to manually change your browser's proxy settings so that they point at Fiddler, but don't want the resulting traffic to be seen, change the "All processes" dropdown in the status bar to "Hide all". This will cause all subsequent traffic to be hidden.

    Regards,
    Eric Lawrence
    Telerik
     

    Build cross-platform mobile apps using Visual Studio and .NET. Register for the online webinar on 03/27/2014, 11:00AM US ET.. Seats are limited.

     
  3. Max
    Max avatar
    2 posts
    Member since:
    Mar 2014

    Posted 24 Mar 2014 in reply to Eric Lawrence Link to this post

    Hi Missing user,

    "Hide all" does the trick. It is definitely more convenient than changing proxy server in the browser, thank you.

    Just to make it clear about the problem: F12 (Capture traffic) does work only for Internet Explorer and Chrome. Firefox has to be configured to use system proxy settings.
    But even that is not the biggest problem. If you have a browser inside a virtual machine (VM) there is no way to affect VM by F12. The same is true for any remote connection to Fiddler.

    I thought it is reasonable to expect that Fiddler does not capture any traffic when it is told to. Instead funny thing happens - you say "Hey Fiddler, stop capturing" and then you go to the browser in a VM and see that Fiddler still captures the traffic :)
  4. EricLaw
    EricLaw avatar
    67 posts
    Member since:
    Oct 2012

    Posted 21 Apr 2014 in reply to Max Link to this post

    As I explained, there's a tradeoff. Fiddler could simply close all inbound connections and let all of the HTTP traffic sent to it fail, but that would cause any device or VM with its settings pointed at that Fiddler instance to fail, potentially causing data loss or other horrible side-effects.
Back to Top