fiddler: connection failed

3 posts, 0 answers
  1. kathy
    kathy avatar
    2 posts
    Member since:
    Jun 2014

    Posted 16 Jun 2014 Link to this post

    I have installed the full version of dot net 4 and fiddler 4 to debug a website on a windows xp pc. But when I open firefox and start fiddler I get the following error in the browser
    [Fiddler] The connection to '' failed.
    Error: InvalidArgument (0x2726).
    An invalid argument was supplied

    I've followed the documentation on the telerik website and googled for a solution but can't find anything.
    Can anybody help?
  2. Eric Lawrence
    Eric Lawrence avatar
    833 posts

    Posted 16 Jun 2014 Link to this post

    Hi, Kathy!

    This error ('WSAEINVAL') is quite unusual. I assume you haven't changed any of the settings inside Tools > Fiddler Options?

    The most likely explanation is that you have Firewall software installed that is blocking Fiddler. Do you have a 3rd party firewall, or are you using the default Firewall that comes with Windows? Have you configured an exception so that Fiddler can interact with the network without blocking?

    Do you have all of the latest updates for your PC installed from WindowsUpdate?

    Eric Lawrence

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

  3. kathy
    kathy avatar
    2 posts
    Member since:
    Jun 2014

    Posted 17 Jun 2014 in reply to Eric Lawrence Link to this post

    Thank you Eric!

    No, I haven't changed any of the settings. Yes, I do use a 3rd party firewall (panda). But I hadn't configured the rules correctly for Fiddler. Now that I have done that, everything is working fine. Thanks  again.

    Well, I like to think that if I'm going to post a question on a forum that it's something 'quite unusual'. At least I succeeded in that! Maybe somebody else will also benefit from this thread.

Back to Top