Fiddler broke Windows 10 : Edge no longer working, Cannot sign in Store, Groove Music

21 posts, 1 answers
  1. Gilles
    Gilles avatar
    4 posts
    Member since:
    Feb 2015

    Posted 19 Sep 2015 Link to this post

    I installed Fiddler (V4.6.0.2 - August 17 2015) on Windows 10 RTM (build 10240) x64 en-US.

    Since then, Edge is no longer working (error "Hmm, we can't reach this page.") unless Fiddler is running.

    Note that Firefox , Chrome and IE11 do not have this issue, they are OK when fiddler is NOT running.

    I restarted the PC several times,the problem is still present.

    I checked the ProxyServer key in HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings : the key is only there when fiddler is running.

    Also I cannot sign in Windows Store or Groove Music unless Fiddler is running AND I've enabled the apps in  "App Container Loopback Exemption Utility" (WinConfig button).

    Note #1: I have a warning  "Orphaned Exemption Record Found" when launching WinConfig, see attached screenshot.

    Note #2: In HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings, I have this key : _FiddlerDirectWrite = "BuggyWinShutdown at 01:07:59 2015-09-17". I don't know if this is normal.

    Note #3 : I searched every location in registry with value "8888" ( fiddler proxy port) when Fiddler was running then I closed Fiddler and looked at the registry locations again.

    I found 8888 in those 2 keys below, so I deleted the keys, restarted the computer but the issue is still there.

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iphlpsvc\Parameters\ProxyMgr\{E6EFF353-402B-45F2-8D72-E8B7FA394DB5}]
    "StaticProxy"="http=127.0.0.1:8888;https=127.0.0.1:8888"
    "ProxyBypass"="<-loopback>"
    "LastUseTime"=hex(b):8a,ce,43,c6,ba,f0,d0,01

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iphlpsvc\Parameters\ProxyMgr\{F9D45E1B-22AA-4CAA-BDA0-DA414B44C2A5}]
    "StaticProxy"="http=127.0.0.1:8888;https=127.0.0.1:8888"
    "ProxyBypass"="<-loopback>"
    "LastUseTime"=hex(b):8a,ce,43,c6,ba,f0,d0,01

     

    From HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles, I can see that:

    {E6EFF353-402B-45F2-8D72-E8B7FA394DB5} is "fortissl" : Fortinet SSL VPN that I use to connect to my company network.

    {F9D45E1B-22AA-4CAA-BDA0-DA414B44C2A5} is "Network" : Ethernet connection

    After I ran fiddler, the key {F9D45E1B-22AA-4CAA-BDA0-DA414B44C2A5} was re-created.

    The other key {E6EFF353-402B-45F2-8D72-E8B7FA394DB5} would probably have been re-created as well if  VPN connection was established when I ran fiddler again.

    Fortinet SSL VPN​ is working fine, I installed it right after Windows 10.

    I had no issue  with Edge or Windows Store until I installed Fiddler 4.

     

  2. Answer
    Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 21 Sep 2015 Link to this post

    Hi, Gilles--

    The only change Fiddler itself makes is to change the proxy settings to point to itself while it runs; those settings are reverted when it exits.

    The "BuggyWinShutdown" registry key tracks whether or not Fiddler ever had to directly overwrite the system proxy settings because the Windows proxy API failed due to a Windows bug (see https://connect.microsoft.com/IE/feedback/details/838086/internet-explorer-10-11-wininet-api-drops-proxy-change-events-during-system-shutdown). The presence of this key simply indicates that Fiddler took this action and doesn't indicate a real problem. 

    The best way to examine your proxy settings is to use IE's Tools > Internet Options > Connections > LAN Settings; this uses the proper API that is used by the browser.

    If Edge is the only browser with problems and IE works fine and Edge works when Fiddler is running, this is a strong indication that the problem is the system's firewall configuration. You might try disabling the Windows Firewall service (using services.msc) temporarily and confirm that this is related.

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Gilles
    Gilles avatar
    4 posts
    Member since:
    Feb 2015

    Posted 21 Sep 2015 Link to this post

    Thanks for the reply, you're right Fiddler does not cause the issue, he just solves (hides) the issue when running.
    The issue was not related to firewall, it happened because the DNS client service (Dnscache) was disabled.

    This is caused by FortiClient VPN SSL, Dnscache is set to disabled state when VPN is connected and it should be set to Automatic when VPN is disconnected (after 1 minute it seems).
    So it look like that VPN did not shut down properly and did not restore Dnscache service (maybe I shutdown the computer while VPN was connected).

    I found something on Fortinet KB, I may try this: http://kb.fortinet.com/kb/documentLink.do?externalID=FD36228
    But at least, I know how to repair this issue now, check that DNS client service is not disabled.

    It is strange that only Edge is affected, others browsers (IE, Firefox, Chrome) are OK when Dnscache is disabled.
  4. Iscariot
    Iscariot avatar
    4 posts
    Member since:
    Sep 2015

    Posted 22 Sep 2015 Link to this post

    Hello

     I just have the same problem...

     

    After using fiddler, all my UWP applications can't connect to any network.

    Such as Edge, OneNote, Store, Weather, etc..

    And I'm pretty sure my DNS Client service is running, my proxy settings are all disabled.Both windows settings and IE settings.

     

    Can anyone tell me what happened and how to fix it ? Thanks a lot.

     

    I've googled a lot but only got this thread.

    Ps.English is not my native language, so sorry for my bad English...
  5. Iscariot
    Iscariot avatar
    4 posts
    Member since:
    Sep 2015

    Posted 22 Sep 2015 in reply to Eric Lawrence Link to this post

    Hello

     

    I've disabled all proxy settings and tried disable windows firewall, doesn't work...

     Edge and other UWP apps still can't connent to Internet.

     

    IE Firefox works fine.

  6. Gilles
    Gilles avatar
    4 posts
    Member since:
    Feb 2015

    Posted 22 Sep 2015 Link to this post

    I'm sorry to hear that but as I wrote, in my case Fiddler was not the problem, it was some kind of solution as Edge was working when Fiddler was running.

    So Fiddler did not break anything, I was wrong, I would have edited the thread title if I could.

  7. Iscariot
    Iscariot avatar
    4 posts
    Member since:
    Sep 2015

    Posted 22 Sep 2015 in reply to Gilles Link to this post

    In my case I only installed Fiddler, and as you said, when Fiddler is running Edge and other apps works fine.

     

    Seems I disabled proxy, but actually they are still affecting my apps? Don't know.

     It's weird...

     

    My platform: Windows 10 build 10240 x64 zh-CN @ Surface Pro 3 i5/128G

     

    Screenshots are in Chinese..If someone needs translate I'll do that later tomorrow

  8. Gilles
    Gilles avatar
    4 posts
    Member since:
    Feb 2015

    Posted 22 Sep 2015 in reply to Iscariot Link to this post

    I'm sorry, I cannot help.
    I'm pretty sure that Eric Lawrence is right, if Proxy Server (in IE's Tools > Internet Options > Connections > LAN Settings) is disabled as it should be when you leave Fiddler then the problem is not Fiddler, you have an issue with Windows or third party software.

    You can also check "ProxyServer" in HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    The value exist when Fiddler is running, it is deleted when you close Fiddler.
  9. Iscariot
    Iscariot avatar
    4 posts
    Member since:
    Sep 2015

    Posted 23 Sep 2015 in reply to Gilles Link to this post

    Anyway, thanks a lot ~

     

    I've checked almost everything...and still don't know what caused my problem.

     

    I'll reinstall my whole system and try to figure out what is affecting.

     

  10. Eric
    Eric avatar
    1 posts
    Member since:
    Oct 2015

    Posted 12 Oct 2015 Link to this post

    I'm having a similar problem.  I upgraded from windows 8 to 10.  When I upgraded some programs couldn't connect with the internet The program I'm having a problem with is called JING  its a screen capture program.  It copies the video to its web server.  For some reason this program is being blocked from the internet.  I had someone from dell look at my computer (its new) they installed fiddler.  The program will work if fiddler is loaded.   I use mcafee - I turned off the firewall.  No difference.  I'm currently stuck. anybody have any ideas?
  11. eric
    eric avatar
    2 posts
    Member since:
    Nov 2015

    Posted 24 Nov 2015 in reply to Gilles Link to this post

    I bought a new computer with windows 8.1 installed.  I upgraded to windows 10 - after I upgraded edge didn't work.  I called Dell , the had me install Fiddler. Wow guess what - Edge now works and so does internet explorer.  Google chrome also now works - non of them will work unless I have fiddler running. I'm not sure why - I think this has to do with windows 8.1 appcontainer technology.  Yes fiddler gives me a error message when I run windows explorer or chrome - it says "orphaned exemption record - no appcontainer with that sid found"    I think this is a windows problem not a fiddler problem.  Anybody know how to fix it?
  12. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 26 Nov 2015 Link to this post

    Hello, Eric--

    Chrome doesn't use AppContainer, and IE only uses it if you turn on Enhanced Protected Mode. What you're describing does sound like a bug in the firewall configuration-- either the third-party one or the one that comes with Windows itself. If you can share the exact text of the error page you see in Chrome, it may shed some light.

    Beyond disabling McAfee's firewall, you may want to verify that the Windows Firewall configuration isn't interfering.

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  13. Paul
    Paul avatar
    4 posts
    Member since:
    Jul 2011

    Posted 29 Nov 2015 Link to this post

    I'm having this same problem. If I run Fiddler, everything works. The second I shut it down, all my network connections from universal apps cease to work at all.
  14. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 29 Nov 2015 Link to this post

    Hi, Paul--

    Unfortunately, you'll probably want to talk to Microsoft Support about this, assuming the suggestion of examining your Windows (or third-party) Firewall settings doesn't bear any fruit.

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  15. Keith
    Keith avatar
    7 posts
    Member since:
    Jan 2016

    Posted 06 Jan in reply to Iscariot Link to this post

    If you are on Win 10 (Edge, Store, One Note, etc makes it sound like you are) I discovered that Fiddler will set the SYSTEM PROXY SETTINGS.  

     Goto Start > Settings > Network & Internet > Proxy and turn it off.

     NOTE:  The next time you start fiddler it will turn it back on!  Exiting Fiddler does not seem to turn the SYSTEM PROXY back off.  :(

  16. EricLaw
    EricLaw avatar
    67 posts
    Member since:
    Oct 2012

    Posted 30 Jan in reply to Keith Link to this post

    Exiting Fiddler normally does, of course, change the system proxy settings back. The one exception to that is if the exit of Fiddler occurs during the system shutdown. With IE10, Microsoft shipped a bug (which they have yet to fix) whereby system proxy changes at shutdown are ignored.

     Restarting Fiddler will detect that the proxy settings were already pointed at Fiddler such that exiting normally (not during shutdown) will clear them.

  17. Rob
    Rob avatar
    2 posts
    Member since:
    Sep 2012

    Posted 04 Mar Link to this post

    FYI, my computer rebooted overnight with fiddler still open. The proxy settings were still there after the reboot causing no browser to work... http=127.0.0.1:8888;https=127.0.0.1:8888
  18. eric
    eric avatar
    2 posts
    Member since:
    Nov 2015

    Posted 04 Mar Link to this post

    Microsoft came out with several large updates for windows 10. That seemed to fix the problem I was having with internet explorer and other programs that were trying to access the internet behind the scenes. Hope this helps
  19. Rihana
    Rihana avatar
    2 posts
    Member since:
    Jul 2016

    Posted 21 Jul Link to this post

    In order to fix the Microsoft Edge Errors like crashing, not responding you should apply a guide, visit: [Solved] Microsoft Edge Closes Immediately after opening
  20. Rihana
    Rihana avatar
    2 posts
    Member since:
    Jul 2016

    Posted 21 Jul Link to this post

    In order to fix the Microsoft Edge Errors like crashing, not responding you should apply a guide, visit:
  21. Rustam
    Rustam avatar
    1 posts
    Member since:
    Sep 2016

    Posted 03 Sep Link to this post

    It seems like Windows 10 firewall is hard-coded to block access from managed apps to the localhost.

    No matter what firewall exception I add, as soon as I enable the proxy to any localhost port (Fiddler or any other app running locally), none of Windows managed apps can access the Internet. Store, Maps, Mail, Edge, etc. - all get a "connection timeout" error.

    The ONLY solution is to (1) turn off the Windows Firewall and (2) then stop the MpsSvc service.

    WTF Microsoft!

Back to Top