failed to load viewstate on every postback

5 posts, 0 answers
  1. -DJ-
    -DJ- avatar
    263 posts
    Member since:
    Oct 2004

    Posted 31 Aug 2009 Link to this post

    Hi,

    I have a very basic setup.

    A very simple grid within a usercontrol.
    I get a "Failed to load viewstate" error on every possible postback: paging, sorting, changing the pagesize...

    I can't see any reasson for this, as I'm using grids in other usercontrols within the same project without any such problems.
    I'm using Q1 2009 by the way.

    I've tried disabling the viewstate in both the grid and the usercontrol, with no luck. If I disable the viewstate in the page the error goes away but I actually need that viewstate for other parts of the page.

    Any thoughts on a solution?

    Regards,
    -DJ-

  2. Pavlina
    Admin
    Pavlina avatar
    6084 posts

    Posted 31 Aug 2009 Link to this post

    Hi -DJ-,

    Based on this information, it is hard to determine what is causing the unwanted behavior. If the problem persists, you can open a formal support ticket, and send us a small working project, demonstrating your setup, as well as the unwanted behavior. We will review it locally, and advise you further.

    Best wishes,
    Pavlina
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Schlurk
    Schlurk avatar
    812 posts
    Member since:
    May 2009

    Posted 31 Aug 2009 Link to this post

    I know this might seem silly but have you tried to simply just re-create the grid within the usercontrol? If the grid is a simple one this shouldn't be too cumbersome, and the last time I got the error re-creating actually fixed it for me.
  5. -DJ-
    -DJ- avatar
    263 posts
    Member since:
    Oct 2004

    Posted 31 Aug 2009 Link to this post

    Thank you Pavlina and Schlurk.

    It wasn't related to the grid in any other way than the grid was creating the postbacks. It was, as I should have realized, because of dynamically added controls elsewhere (in the master page).

    Regards,
    -DJ-
  6. Pavlina
    Admin
    Pavlina avatar
    6084 posts

    Posted 01 Sep 2009 Link to this post

    Hi -DJ-,

    I am glad to hear that you have found what is the problem in your project.
    Please do not hesitate to let us know if other questions or problems arise.

    Greetings,
    Pavlina
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017