Export to PDF (Arabic / Persian Language) problem

8 posts, 0 answers
  1. Amir Akhoundpour
    Amir Akhoundpour avatar
    3 posts
    Member since:
    Oct 2009

    Posted 10 Oct 2009 Link to this post

    Dear Support,

    I generate a report which it has Persian(farsi or Arabic) data, it work fine and I can export it to different format, but I could not print or export it to PDF format. it shows "-" instead of my data and I could not find any setting for change report for supporting RTL languages , arabic or Persian language.
    What should I do to make the report to show these data?

    Here I attach the PDF view of my report(incorrect data) and my report in report viewer(correct Data).

    Regards,
    Amir
  2. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 12 Oct 2009 Link to this post

    Hello Amir,

    We're aware of a wrong behavior observed when you print from the web viewer a report with numbers/dates and Arabic/Persian culture and this is now logged into our issue tracking system. However we have not been able to reproduce this with text (see attached screenshot).
    Please verify that you have localized the report properly by setting the Report Localizable property to true and selecting for the Language property "Persian" culture.

    Kind regards,
    Steve
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. DevCraft banner
  4. Amir Akhoundpour
    Amir Akhoundpour avatar
    3 posts
    Member since:
    Oct 2009

    Posted 12 Oct 2009 Link to this post

    Hello Steve,

    I change the culture property to"Persian" but it doesn't work properly, then I change the default text component to HTMLText , then it shows the correct data in viewer and PDF format.
    I think the Telerik textbox has some problem in Persian / Arabic languages.

    Best Regards,
    Amir
  5. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 13 Oct 2009 Link to this post

    Hello Amir,

    Do you mean that you've replaced the TextBox item with the HtmlTextBox and it started working properly? Although we've not been able to replicate this on our end we would research on this as well, when looking into the numbers/dates issue.

    Kind regards,
    Steve
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. Amir Akhoundpour
    Amir Akhoundpour avatar
    3 posts
    Member since:
    Oct 2009

    Posted 13 Oct 2009 Link to this post

    Dear Steve,

    Yes, I replace TextBox to HTMLTextBox and it works properly.

    Best Regards,
    Amir
  7. Lobna
    Lobna avatar
    14 posts
    Member since:
    Jan 2013

    Posted 02 Feb 2015 Link to this post

    it depends on the font type too, with calibri font it didn't show Arabic but when changed to Tahoma or Times New Roman it works.
  8. radhika
    radhika avatar
    7 posts
    Member since:
    Dec 2015

    Posted 19 Jan Link to this post

    Hello,

    I have tried all solutions listed above but am not able to display reports in different Language. I am not able to convert English static text (Column Header Text) to Arabic in Crosstab Tool. Is there any sample available on how to achieve this kind of functionality?

     Regards,

    Radhika

  9. Stef
    Admin
    Stef avatar
    3036 posts

    Posted 21 Jan Link to this post

    Hello Radhika,

    Please check my last post in the Report Localization / Globalization Problem forum thread.

    Regards,
    Stef
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top
DevCraft banner