Even in your demos

6 posts, 1 answers
  1. Bill
    Bill avatar
    85 posts
    Member since:
    Oct 2007

    Posted 21 May 2010 Link to this post

    I'm sure this is not what you wanted your demo to do, but it is something that happens all too often with all telerik controls I've used so far...
  2. Bill
    Bill avatar
    85 posts
    Member since:
    Oct 2007

    Posted 21 May 2010 Link to this post

    Another example from your latest demos
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Answer
    Kamen Bundev
    Admin
    Kamen Bundev avatar
    1532 posts

    Posted 25 May 2010 Link to this post

    Hi Bill,

    There is at least one IE8 compatibility mode that is undetectable on the server. Press F12 and check if your Browser Mode is IE8 Compat View and Document Mode is IE8 Standards - this particular mode selection should be impossible in the wild unless Developer Tools is used to select it.

    However one can manage to trigger it if local intranet is forced to open by default in compatibility view (clean IE8 after installation has this option enabled) and has forced IE8 browser mode with one of these meta tags in your pages:
    <meta http-equiv="X-UA-Compatible" content="IE=Edge" />
    <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" />
    <meta http-equiv="X-UA-Compatible" content="IE=8" />
    This combination will always trigger this compatibility mode bug while browsing in local intranet.

    There are two solutions to this issue - the first is obviously to stop the compatibility mode for local intranet in the Compatibility View settings but this should be done on every computer which should access the site. The other is to sacrifice the horizontal scrolling of RadScheduler by adding the following (very hacky) CSS to your stylesheet:
    div.RadScheduler .rsHorizontalHeaderTable,
    div.RadScheduler .rsContentTable
    {
        width /*\**/: 100%\9 !important;
    }
    *+html div.RadScheduler .rsHorizontalHeaderTable,
    *+html div.RadScheduler .rsContentTable
    {
        width: auto !important;
    }

    It should work in all browsers, including all IE8 and all IE9 compatibility modes which I tested. Let me know if this helps.

    Regards,
    Kamen Bundev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Bill
    Bill avatar
    85 posts
    Member since:
    Oct 2007

    Posted 26 May 2010 Link to this post

    It did get "into the wild" here - somehow it's set in the workstation image they've been pushing out to desktops here.
  6. Bill
    Bill avatar
    85 posts
    Member since:
    Oct 2007

    Posted 11 Jun 2010 Link to this post

    Is there something else that will trigger this?
    I'm now getting this same problem in your demos and my own pages on my dev. machine when I click on "view in browser" for any page.... and there are none of these settings in the meta data tags on any of my pages...
  7. Kamen Bundev
    Admin
    Kamen Bundev avatar
    1532 posts

    Posted 16 Jun 2010 Link to this post

    Hello Bill,

    Can you check in your Compatibility View settings if our site fell in the always render in compatibility mode category? Also make sure that the checkbox Display all websites in Compatibility view (and the intranet sites for your dev machine) is switched off.

    Best wishes,
    Kamen Bundev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017