Error: Unexpected value 'SIDEDRAWER_DIRECTIVES' declared by the module

6 posts, 1 answers
  1. License
    License avatar
    43 posts
    Member since:
    Oct 2016

    Posted 18 Dec 2016 Link to this post

    Hi,

    I have met a problem.

    Use version 0.2.11
    After the command npm run start-android-bundle in step webpack --config = webpack.android.js --progress out error
    Error: Unexpected value 'SIDEDRAWER_DIRECTIVES' declared by the module 'AppModule'
    in \node_modules\@angular\compiler\bundles\compiler.umd.js:14722:29
    Use Angular, AppModule is main and one application module.
    SIDEDRAWER_DIRECTIVES from plugins nativescript-telerik-ui

    Can you help me?

  2. nikolay.tsonev
    Admin
    nikolay.tsonev avatar
    191 posts

    Posted 19 Dec 2016 Link to this post

    Hi,

    Thank you for reporting this issue,

    I reviewed your case, unfortunately I have to confirm that this is an issue, while using webpack with the present version of nativescript-telerik-ui. We will do everything possible to address the problem. In the meantime you could build your project, without using webpackYou could also keep track on the new features updates and fixes in our Release notes section.

    Let me know whether this helps.


    Regards,
    nikolay.tsonev
    Telerik by Progress
    Did you know that you can open private support tickets which are reviewed and answered within 24h by the same team who built the components? This is available in our UI for NativeScript Pro + Support offering.
  3. License
    License avatar
    43 posts
    Member since:
    Oct 2016

    Posted 19 Dec 2016 Link to this post

    Hi,

    Thank you so much .But can I know that when will be  your next release probably ?

    Regards!

     

  4. Answer
    nikolay.tsonev
    Admin
    nikolay.tsonev avatar
    191 posts

    Posted 20 Dec 2016 Link to this post

    Hi License,

    The new version of UI for NativeScript will be available in early 2017, though I cannot give an exact date.
    You could also keep track on the new features updates and fixes in our Release notes section, where you will find  all bug fixes, when the new version has been published.

    Hope this information helps.
    Regards,
    nikolay.tsonev
    Telerik by Progress
    Did you know that you can open private support tickets which are reviewed and answered within 24h by the same team who built the components? This is available in our UI for NativeScript Pro + Support offering.
  5. Upender
    Upender avatar
    1 posts
    Member since:
    Jun 2015

    Posted 10 Jan Link to this post

    I am also facing the same issue when using "nativescript-dev-webpack".

    Any update on this?

  6. nikolay.tsonev
    Admin
    nikolay.tsonev avatar
    191 posts

    Posted 13 Jan Link to this post

    Hello,

    Next version of UI for NativeScirpt will be published in the next two weeks.

    However due to some issues,  the feature, which provides support for webpack, will not be available in next version 1.6.0 .

    Regarding to that, webpack support should come after 1.6 release, though I still cannot give an exact date.

    For more info you could also keep track on this issue, where this problem has been already reported.

    Regards,
    nikolay.tsonev
    Telerik by Progress
    Did you know that you can open private support tickets which are reviewed and answered within 24h by the same team who built the components? This is available in our UI for NativeScript Pro + Support offering.
Back to Top