Error Rendering Controls

5 posts, 1 answers
  1. Tim
    Tim avatar
    60 posts
    Member since:
    May 2011

    Posted 09 Jun 2011 Link to this post

    My company just purchased the Developer license for the ASP.NET version 2011.1.519.35 control set. After complete removal of the trial version and re-installation of the purchased product I am now receiving the error in the attached controlerror.png file. I removed all instances of Telerik from the web.config during the removal of the Trial version. I then copied the new telerik.web.ui.dll and placed it into the solution libary folder and references that dll in the solution. I then ran the 'configure project' selection from Telerik menu to bring my web.config into compliance for this version. No existing controls in the project will render either all controls are showing different errors ( see attached Page1Errors.png) any help would be appreciated.
  2. Tim
    Tim avatar
    60 posts
    Member since:
    May 2011

    Posted 10 Jun 2011 Link to this post

    I solved the issue by placing a copy of the Telerik.Web.UI.dll in both of the folders mentioned in the ControlError.png file. My concern now is why didn't a clean install prep this. I uninstalled the trial and then open VS2008 to ensure the toolbox would reload and clear the Telerik control reference and then I installed the retail version. Somewhere along the way the pointers back to the new dll files did not get propagated properly
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Tim
    Tim avatar
    60 posts
    Member since:
    May 2011

    Posted 10 Jun 2011 Link to this post

    Ok, can someone explain to me why after compiling and running the application it needs to keep copying the dll to a different temp folder under \project Assemblies? Now all my controls have errors again in design time. Both images from my initial post are once again applicable. This is not a desired behavior and will become a deal breaker in moving forward with development with these controls if this continues. I am also submitting a support ticket for this thread.
  5. Answer
    Pavlina
    Admin
    Pavlina avatar
    6084 posts

    Posted 10 Jun 2011 Link to this post

    Hi Tim,

    I think that the information from the help topic linked below will help you address the errors you currently receive:
    http://www.telerik.com/help/aspnet-ajax/introduction-design-time-troubleshooting.html

    Please examine it and let me know if it helps to resolve the problem you are facing.

    Regards,
    Pavlina
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

  6. Tim
    Tim avatar
    60 posts
    Member since:
    May 2011

    Posted 10 Jun 2011 Link to this post

    Copying the Telerik.Web.Design.dll in the bin folder seemed to work. I'll keep my eye on it. Thanks Pavlina
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017