Error registring httphandler - it cant load 'Telerik.Cms.Web.UI' Feed from this threadSubscribe for this thread

2 posts, 0 answers
  1. ithihas
    ithihas avatar
    14 posts
    Member since:
    Jun 2012

    Posted 26 Jul 2012 Link to this post

    • Hello, Telerik Team

      I got a problem to register the httphandler for the captcha control. Like this document says I placed this two codes in the web.config

      <httpHandlers>  
            
      <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.CaptchaImageHandler"verb="*" validate="false" />  
      </httpHandlers>  
       
      <handlers>  
           
      <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode"path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.CaptchaImageHandler" />  
      </handlers>


      But as this is done I still get this error on my page.
        

      Server Error in '/' Application.

      Configuration Error

      Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

      Parser Error Message: Could not load file or assembly 'Telerik.Cms.Web.UI' or one of its dependencies. The system cannot find the file specified.

      Source Error: 

      Line 61: 			<add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/>
      Line 62: 			<add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false"/>
      Line 63: <add verb="GET" path="CaptchaImage.axd" type="Telerik.Web.UI.SpamProtection.Captcha.CaptchaImageHandler, Telerik.Cms.Web.UI" />Line 64:     </httpHandlers>
      Line 65: 		<httpModules>

      Source File: C:\Users\jmi01\Desktop\custom-image-editor-updated\Custom_Image_Editor\web.config    Line: 63 

      Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Cms.Web.UI' could not be loaded.

      === Pre-bind state information ===
      LOG: User = WALBEEKGROEP\jmi01
      LOG: DisplayName = Telerik.Cms.Web.UI
       (Partial)
      LOG: Appbase = file:///C:/Users/jmi01/Desktop/custom-image-editor-updated/Custom_Image_Editor/
      LOG: Initial PrivatePath = C:\Users\jmi01\Desktop\custom-image-editor-updated\Custom_Image_Editor\bin
      Calling assembly : (Unknown).
      ===
      LOG: This bind starts in default load context.
      LOG: Using application configuration file: C:\Users\jmi01\Desktop\custom-image-editor-updated\Custom_Image_Editor\web.config
      LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework\v2.0.50727\config\machine.config.
      LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).
      LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/root/ace6216c/3fd55b01/Telerik.Cms.Web.UI.DLL.
      LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/root/ace6216c/3fd55b01/Telerik.Cms.Web.UI/Telerik.Cms.Web.UI.DLL.
      LOG: Attempting download of new URL file:///C:/Users/jmi01/Desktop/custom-image-editor-updated/Custom_Image_Editor/bin/Telerik.Cms.Web.UI.DLL.
      LOG: Attempting download of new URL file:///C:/Users/jmi01/Desktop/custom-image-editor-updated/Custom_Image_Editor/bin/Telerik.Cms.Web.UI/Telerik.Cms.Web.UI.DLL.
      LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/root/ace6216c/3fd55b01/Telerik.Cms.Web.UI.EXE.
      LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/root/ace6216c/3fd55b01/Telerik.Cms.Web.UI/Telerik.Cms.Web.UI.EXE.
      LOG: Attempting download of new URL file:///C:/Users/jmi01/Desktop/custom-image-editor-updated/Custom_Image_Editor/bin/Telerik.Cms.Web.UI.EXE.
      LOG: Attempting download of new URL file:///C:/Users/jmi01/Desktop/custom-image-editor-updated/Custom_Image_Editor/bin/Telerik.Cms.Web.UI/Telerik.Cms.Web.UI.EXE.
      

       


      Version Information: Microsoft .NET Framework Version:2.0.50727.4016; ASP.NET Version:2.0.50727.4016 


      Hope you guyes can help me out with this problem.

      Thanks in advance,

  2. Slav
    Admin
    Slav avatar
    1356 posts

    Posted 27 Jul 2012 Link to this post

    Hi Pradeep,

    Did you try the suggestion from this forum thread, which you have most probably examined? Please remove the line, marked in the exception, as it is not required and check if the problem is resolved.

    Greetings,
    Slav
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top