Error Creating Template Groups. Reson:System.InvalidCastException

8 posts, 0 answers
  1. navyateja
    navyateja avatar
    17 posts
    Member since:
    Jan 2007

    Posted 04 Jan 2010 Link to this post

    Hello,

    When I switch to designer view in VS2008 with at radgrid on the page I am receiving following error. "Error Creating Template Groups. Reason:System.InvalidCastException"

    I have attached the complete error for reference. As suggested in pervious posts, I cleared all the Project assemblies, temporary files in Microsoft.NET\Framework\v2.0.50727 folder and checked all the references.

    Any help is appreciated.

    Thanks,
    Teja.
  2. Pavlina
    Admin
    Pavlina avatar
    6084 posts

    Posted 05 Jan 2010 Link to this post

    Hi Teja,

    Please check out the following forum post which elaborates on this subject, for more information about how to avoid this error:
    http://www.telerik.com/community/forums/aspnet-ajax/general-discussions/ajax-2-9-q2-release-giving-me-gray-hair.aspx

    Greetings,
    Pavlina
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Jim
    Jim avatar
    17 posts
    Member since:
    May 2010

    Posted 19 Dec 2011 Link to this post

    When trying to access the above link, I get the following:

    Oops...

    It seems there was a problem with our server.

    Any chance of just posting the contents of that link on this page?
  5. Pavlina
    Admin
    Pavlina avatar
    6084 posts

    Posted 19 Dec 2011 Link to this post

    Hi Jim Youngman,

    You can find the needed information in the following link:
    http://www.telerik.com/community/forums/aspnet-ajax/general-discussions/ajax-2009-q2-release-giving-me-gray-hair.aspx

    Kind regards,
    Pavlina
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  6. Jim
    Jim avatar
    17 posts
    Member since:
    May 2010

    Posted 19 Dec 2011 Link to this post

    That did the trick!  Thank you!
  7. Nick
    Nick avatar
    10 posts
    Member since:
    Feb 2012

    Posted 07 Aug 2014 in reply to Pavlina Link to this post

    Rather than adding links to other blog post could you post a solution to this issue?  I've been having this issue since the last I updated our Telerik Libraries and even though I've found ways to work around it, the error is very frustrating.  I'd love to just have a link to a page with step by step instructions on how to resolve it.

  8. Nick
    Nick avatar
    10 posts
    Member since:
    Feb 2012

    Posted 07 Aug 2014 in reply to Pavlina Link to this post

    Rather than adding links to other blog posts could you post a solution to this issue?  I've been having this problem ever since the last I time updated our Telerik Libraries and even though I've found ways to work around it, the error is very frustrating.  I'd love to just have a link to a page with step by step instructions on how to resolve it.
  9. Pavlina
    Admin
    Pavlina avatar
    6084 posts

    Posted 12 Aug 2014 Link to this post

    Hi,

    The reason for this error to happen could vary. It is possible to appear only in design-time, run-time or both. If it only appears in design time you can refer to the article below:
    http://www.telerik.com/help/aspnet-ajax/introduction-design-time-troubleshooting.html

    If the error appears both in design time and runtime, this could happen if your solution consists of various projects and some of the projects refer to a different version of the Telerik.Web.UI assembly than the main project (WebApplication/WebSite).

    Therefore, you can check whether clearing your VS cache and restarting your development environment addresses the issue you encountered? You may also check whether you have a valid reference to the Telerik.Web.Design.dll either in the /bin folder of your project or in the GAC on your machine. Also make sure that the version of Telerik.Web.UI is the same for all the projects.

    Regards,
    Pavlina
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017