Error Creating Control in VS design view

3 posts, 1 answers
  1. John
    John avatar
    11 posts
    Member since:
    Mar 2015

    Posted 12 May 2015 Link to this post

    Is there a way to prevent this? It makes life difficult when you can't use the design view. (see attached)

    Note, this happens everywhere in the project.

  2. Answer
    Vessy avatar
    1350 posts

    Posted 13 May 2015 Link to this post

    Hi John,

    The most probable reason for the experienced error could be a previous version DLLs cached in the GAC. This is so, could you verify that  the installation PC was restarted after the installation?

    If you have already done it, though, and the problem still exists, there might has been some warnings in the installation wizard, preventing some DLLs to be referred properly. Automated tools may not always produce the expected results, the following manual approach should let you upgrade in a manner of minutes: Upgrade the Version of Your Telerik ASP.NET Controls in 6 Easy Steps

    If the controls in your application are registered with their fully qualified name, you have to make sure that they are pointing to one and the same version (probably the latest installed one).

    You can find more information about the Global Assembly Cache and how to add/remove dlls from it in the following blog post: Working with Assemblies in the GAC

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. DevCraft R3 2016 release webinar banner
  4. John
    John avatar
    11 posts
    Member since:
    Mar 2015

    Posted 13 May 2015 in reply to Vessy Link to this post

    Doing an upgrade has fixed it.

    Thanks very much.

Back to Top