Error changing to deploy global

6 posts, 0 answers
  1. Frits
    Frits avatar
    3 posts
    Member since:
    Aug 2007

    Posted 15 Aug 2007 Link to this post

    I am beginning to work with WSS3 for our Intranet. As a Graphic Prepress Center we use many Mac's. So we found RadEdit lite.
    Yesterday I installed it and deployed in the central admin. I deployed it in one site. It gave the line Deployed   in http://intranet.
    But then I thought that I could better deploy it globally(to all Content web Applications). So I clicked on retract solution. But then it came back with an error. And I have only the choice to go back to the solution.
    Is there a way to correct this.
    PS. I use Dutch version of WSS3.
  2. Lini
    Admin
    Lini avatar
    2144 posts

    Posted 15 Aug 2007 Link to this post

    Hello Frits,

    What is the error you get when you try to retract the solution?

    You can try to manually retract and remove the solution with the following commands (execute them from the command prompt on the server):

    stsadm -o retractsolution -name RadEditorMOSS.wsp -immediate -allcontenturls
    or
    stsadm -o retractsolution -name RadEditorMOSS.wsp -immediate -url http://intranet

    ...
    wait a few minutes for the job to finish
    ...

    stsadm -o deletesolution -name RadEditorMOSS.wsp


    Kind regards,
    Lini
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center

  3. Frits
    Frits avatar
    3 posts
    Member since:
    Aug 2007

    Posted 15 Aug 2007 Link to this post

    Thanks for the quick reaction.

    I try to retract now through the command line as you described.
    I get the message that the solution radeditormoss.wsp is already being deployed or retracted. This operations cannot be performed at the same time. (translated from Dutch). So it seems that it is not finished with deploying or retracting yet. Stopping and starting the webserver and even rebooting the server does not have any effect. He has the status busy I think. Can I delete the solution as you described or can I perform the addsolution once more. Or is there perhaps a file or so that has to be deleted.
    Because I'm new on this point, in the install manual is mentioned that you have to change the webconfig. How or where can I find that.

    When I clicked on the Retract link yesterday perhaps it was to close after the clicking deploy, however it was mentioned as deployed in the central administration page. The situation now is that he gives there in the web interface a few installed solutions (from the microsoft site.)
    and as the last the radedit.
    Behind all the solutions is written: deployed, and then globally
    behind the Radedit is written fout (Dutch for error) and then http://intranet/
  4. Lini
    Admin
    Lini avatar
    2144 posts

    Posted 16 Aug 2007 Link to this post

    Hi,

    I think that you can cancel the deployment/retraction job with the stsadm command:

    stsadm –o canceldeployment –id <time job guid>

    To get the time job guid, go to central administration and click operations. Then click the Timer Jobs Definitions link from the Global Configuration panel. After you cancel the deployment job, you can try to remove the solution and add it again globally.

    Regards,
    Lini
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. Frits
    Frits avatar
    3 posts
    Member since:
    Aug 2007

    Posted 18 Aug 2007 Link to this post

    Hello Lini,
    With your instructions and some trial and testing it has been implemented ok.  Ther was also a warning that the administration service was not started. So I started that and set it to automatically. After that I could perform the operation.
    Now I can edit texts from Mac. However not in the standard web parts like anouncements, but only in the special webparts.
    But I understood from the site that this was normal that way.
    So we can work on to make the demo sites ready to present to our staff and management.
    One question not yet answered, in the install instructions is written that you finally have to change the webconfig, wich file or setting do ytey mean by that. As a beginner in IIS and WSS I do not know exactly all the settings everywhere. Please give me another hint for that.

    At all I will thank you for the quick and good support.
  6. Lini
    Admin
    Lini avatar
    2144 posts

    Posted 20 Aug 2007 Link to this post

    Hello,

    Thank you for the information. I assume that you are referring the following part from the installation instructions:

    Note: After you have completed the installation you need to modify the web.config of your SharePoint application and set the Trust level to at least Medium level. Otherwise RadEditor for MOSS might not work properly.

    This part is optional. You do not have to change the web.config file unless you see errors of the type "Request for a permission of type...". We will modify the documentation to reflect that. We will also add a note that you need the SharePoint Administration service turned on.

    Kind regards,

    Lini
    the Telerik team


    Instantly find answers to your questions at the new Telerik Support Center
Back to Top