Error attaching device storage for iPad

4 posts, 0 answers
  1. Joshua
    Joshua avatar
    4 posts
    Member since:
    Feb 2012

    Posted 20 Jan 2014 Link to this post

    Project LiveSync mysteriously stopped working on our development iPad mini (iOS7).  When hovering the LiveSync toggle, the message "LiveSync is not attached but it can be attached because project is deployed.  Click to attach LiveSync" appears.  However, upon clicking the toggle nothing happens.  In the log, the message "Error attaching device storage for iPad" appears (and will every time you click the toggle).  I am able to deploy the app successfully via both iTunes and Icenium.  If I take a picture with the iPad's camera, it shows up in File Explorer on the PC I'm using to develop.

    I gave up and then tried to use Ion to update the app.  That reports itself as working properly, however a three-finger gesture does nothing on the device itself despite changes being made to the application.

    LiveSync is working properly with an attached Android phone running KitKat 4.4.2.  The issue first showed up after connecting the Android phone to the PC while the iPad was still connected.

    Here are the steps I've taken thus far to attempt to resolve the issue:
    Verify there are no errors in my application which may be causing the issue.
    Power cycle the iPad.
    Remove the data cable and re-insert it.
    Uninstall the application from the iPad, and then redeploy it via the "Build and Deploy" option.
    Uninstall the application and manually install the ipa via iTunes
    Reset the trust relationship between the iPad and the machine
    Verify that I can communicate with the iPad via other means
    Factory reset the iPad
    Remove all devices, restart computer, power-cycle iPad, uninstall the application from the machine, re-attach devices and reinstall using both the methods outlined above.

    So far, no luck.  Any insight would be greatly appreciated.
  2. Joshua
    Joshua avatar
    4 posts
    Member since:
    Feb 2012

    Posted 21 Jan 2014 Link to this post

    One day later, and it mysteriously started working again this morning.

    However, after several hours of it working, it then stopped working again.  Same message.  Same steps followed.  No solution to be had.
  3. Joshua
    Joshua avatar
    4 posts
    Member since:
    Feb 2012

    Posted 22 Jan 2014 Link to this post

    Okay, so this ended up being something incredibly easy to fix, but I'd still consider this a bug as the messaging provided was substandard to say the least.

    For future internet denizens looking to solve this problem: Make sure your applications build settings are set to "Debug" mode.  I'd been switching to Release for nightlies, and have it work through several changes and then after doing a "Build and Deploy" again it would no longer work on the device.  Switching back to "Debug" and redeploying to the device will make this work again.

    The messaging needs to be much more descriptive when this is an issue.  Disabling the LiveSync toggle with a message that the build is set to release would provide a significantly improved user experience.  The fix is easy, however it's very obscured and took much more hunting than it should have.
  4. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 22 Jan 2014 Link to this post

    Hi Joshua,

    Indeed the build settings have caught many users off guard. We agree that improving the ON/OFF switch to reflect the app build setting is a good idea and you can go ahead and post it in our feedback portal, the more users vote for it, the bigger the chance it gets implemented sooner.

    For the time being, please use our forum search for any issues you encounter, as they are most likely already covered there e.g.:

    Regards,
    Steve
    Telerik
    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
Back to Top