Error after installing 2009 Q3 sp1

7 posts, 0 answers
  1. CSurieux
    CSurieux avatar
    465 posts
    Member since:
    Jan 2007

    Posted 09 Dec 2009 Link to this post

    Hello,
    After install on Vista where the Q3 2009 was running ok (and uninstalled)
    Seems some ria assembly is missing, what to do ?

    I get this error when trying to start demos:
     

    Erreur du serveur dans l'application '/'.

    Erreur de configuration

    Description : Une erreur s'est produite lors du traitement d'un fichier de configuration requis pour répondre à cette demande. Veuillez consulter ci-dessous les détails relatifs à l'erreur en question, puis modifier votre fichier de configuration de manière appropriée.

    Message d'erreur de l'analyseur: Impossible de charger le fichier ou l'assembly 'System.Web.Ria, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' ou une de ses dépendances. Le fichier spécifié est introuvable. (C:\Program Files\Telerik\RadControls for Silverlight Q3 2009 SP1\Demos\ExamplesWeb\web.config line 76)

    Erreur source:

    Ligne 74 :     <httpModules>
    Ligne 75 :       <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    Ligne 76 : <add name="DomainServiceModule" type="System.Web.Ria.Services.DomainServiceHttpModule, System.Web.Ria,Version=2.0.0.0,Culture=neutral,PublicKeyToken=31BF3856AD364E35"/>Ligne 77 :     </httpModules>
    Ligne 78 :   </system.web>

    Fichier source : C:\Program Files\Telerik\RadControls for Silverlight Q3 2009 SP1\Demos\ExamplesWeb\web.config    Ligne : 76


    Informations sur la version : Version Microsoft .NET Framework :2.0.50727.4200; Version ASP.NET :2.0.50727.4016
  2. Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 10 Dec 2009 Link to this post

    Hello,

     The grid demos now depends on the new version of RIA services - now called WCF RIA services. You can get them from here:

    http://silverlight.net/getstarted/riaservices/


    Greetings,
    Vlad
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. DevCraft banner
  4. Jay
    Jay avatar
    7 posts
    Member since:
    Oct 2009

    Posted 10 Dec 2009 Link to this post

    I am getting this error too. I already have WCF RIA for silverlight 4. Should I use WCF RIA for silverlight 3? I think WCF RIA for SL 3 and SL 4 both can not co-exist. As soon as you install WCF RIA for SL 4 it removes older version.

    Please let me know what should I do.

    Thanks.
  5. Arthur Wu
    Arthur Wu avatar
    24 posts
    Member since:
    Apr 2009

    Posted 10 Dec 2009 Link to this post

    I got the same error.My WCF RIA services version=1.0.10.14. <= release 12/3/2009
    I remember,When I install the 2009 Q3  last week.I run the Gridview demo at local and press the Populating with Data>RIA services with DomainDataSource . Only this sample have not  Data show in this Gridview .
    Today I install 2009 Q3 sp1 get the httpModules  problem too.
    Is  2009 Q3  can't  load data because I use RIA services for SL4  ?
  6. Milan
    Admin
    Milan avatar
    1989 posts

    Posted 10 Dec 2009 Link to this post

    Hi Arthur Wu,

    Currently our examples rely on WCF Ria Services for Silverlight 3 and they are not compatible with the Ria bits that target the Silverlight 4 framework.


    Greetings,
    Milan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  7. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 10 Dec 2009 Link to this post

    Currently our examples rely on WCF Ria Services for Silverlight 3 and they are not compatible with the Ria bits that target the Silverlight 4 framework.

    Makes sense!!!
  8. Matias Espinoza
    Matias Espinoza avatar
    1 posts
    Member since:
    Jan 2010

    Posted 07 Jan 2010 Link to this post

    Do I have the same error as I fix this?
Back to Top
DevCraft banner