Enable/Disable for JustCode

42 posts, 0 answers
  1. Steve
    Steve avatar
    9 posts
    Member since:
    Jan 2013

    Posted 14 Nov 2013 Link to this post

    I have to disable JustCode every time I open a project.

    How do I disable it for good other then uninstalling it as I would like to use in in new development but not in maintaining a legacy application?



    Under "Tools => Extensions and Updated", the JustCode buttons are disabled

  2. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 19 Nov 2013 Link to this post

    Hi Steve,

    With the upcoming version of JustCode you will be able to turn it off permanently. The command is located at JustCode menu > Help > Disable JustCode.
    Thanks.

    Regards,
    Zdravko
    Telerik
    Share what you think about JustCode with us, so we can help you even better! You can use the built-in feedback tool inside JustCode, our forum, or our JustCode feedback portal.
  3. deepak
    deepak avatar
    1 posts
    Member since:
    Sep 2014

    Posted 15 Sep 2014 Link to this post

    FYI: There is no such feature available  to disable and enable just code here(Tools > Add-in Manager).

    Can add the image where it is . Only Telerik data access check bx is there(Tools > Add-in Manager)

    I'm using VS2013
  4. Ivan
    Admin
    Ivan avatar
    106 posts

    Posted 17 Sep 2014 Link to this post

    Hello,

    We have changed the location of the Enable/Disable command. You can now find it in JustCode -> Help -> Enable(Disable) JustCode.

    Regards,
    Ivan
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  5. Deepak Shakya
    Deepak Shakya avatar
    118 posts
    Member since:
    Aug 2007

    Posted 11 Feb 2015 Link to this post

    I couldn't find the option at first as well and hence I landed up in this post. But to close the post - I can see the option to Enable/Disable JustCode under the tab: JustCode>Help>Enable/Disable Justcode.

    Worked fine with me. Sometimes, I just need it to be disabled and just code.
  6. Chris
    Chris avatar
    9 posts
    Member since:
    Jun 2012

    Posted 04 Jun 2015 Link to this post

    Every time I typed a character in Visual Studio 2015 in my WPF project.  Just Code would lock up Visual Studio.  I just disabled Just Code and it is now working fine.  Not sure what caused Just Code to suddenly decide it would lock up everything, when it was working perfectly prior.

     

    But just an FYI if you have a Visual Studio Locking up when you enter a character try disabling Just Code first, as it seems like it is likely the reason for it locking up.

  7. Svetlozar
    Admin
    Svetlozar avatar
    281 posts

    Posted 05 Jun 2015 Link to this post

    Hello,

    I am really sorry for the inconvenience!

    Could you please clarify which version of JustCode you have on your side?

    We had a racing issue that is already fixed. Could you please try our latest internal build?

    Regards,
    Svetlozar
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  8. Chris
    Chris avatar
    9 posts
    Member since:
    Jun 2012

    Posted 05 Jun 2015 in reply to Svetlozar Link to this post

    Version Q1 2015 SP1 (2015.1.331.1)
  9. Svetlozar
    Admin
    Svetlozar avatar
    281 posts

    Posted 05 Jun 2015 Link to this post

    Hi,

    Could you please try with our latest internal build? We fixed that freeze problem.

    Regards,
    Svetlozar
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  10. Jan
    Jan avatar
    58 posts
    Member since:
    May 2010

    Posted 21 Sep 2015 Link to this post

    JustCode is taking almost 2Gb of memory!!

    I know my solution ha quite a few projects but still... Justcode uses more memory than Visual Studio itself....

  11. Svetlozar
    Admin
    Svetlozar avatar
    281 posts

    Posted 23 Sep 2015 Link to this post

    Hi,

    I am really sorry for the inconvenience!

    We are aware of  that problem. Our Visual Studio 2015 version maintains Roslyn workspace and we have already identified areas for memory optimizations. 

    Please, stay tuned for our future builds. 

    Regards,
    Svetlozar
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  12. Mark
    Mark avatar
    1 posts
    Member since:
    Sep 2010

    Posted 18 Aug 2016 in reply to Mike Link to this post

    Hopefully you've bought more RAM by now... you need at least 16Gb to be productive with an I7 proc using SSD drives... just my humble opinion.
Back to Top