Editor is changing the font name automatically

7 posts, 0 answers
  1. kartik
    kartik avatar
    11 posts
    Member since:
    Jun 2014

    Posted 04 Jan Link to this post

    Hi,

    When i paste text from MS word (Times New roman, 12 pt) in to the editor, the editor is changing the font name to 'Segoe UI' for some part of the text automatically. This issue is with only some of the word documents i have. I am not able to attach the same word document with this thread as there is no option to attach word format but i have tested it on http://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx link and the same issue exists.

  2. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 05 Jan Link to this post

    Hi Kartik,

    I suspect Times New Roman font is the default font-family for the document used. When content from MS Word is being pasted, the transferred data has no information about the default font-family that is used in MS Word. Therefore, it does not apply one in the pasted HTML content. 

    The applied font in such case is the default for the browser or, the page's default font size. The demo page have Segoe UI font as default and this is the default font-family that is applied and shown in RadEditor. 


    As for attaching an MS Word file, you can just add it to a zip archive and attach the zip file to your message. 

    Regards,
    Ianko
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. kartik
    kartik avatar
    11 posts
    Member since:
    Jun 2014

    Posted 05 Jan in reply to Ianko Link to this post

    Hi Lanko,

    Thanks a lot for the response.

    As i strictly need the text with font name 'Time New Roman', i tried the following  steps:
    1. Copied all the text to new word document whose default font-family was 'Calibri'. The font - family changed to 'Time New Roman' (font family of original text) correctly.

    2. Saved the new word document.

    3. Copied the text from the new word document to the Telerik Editor and checked the same issue and it got generated again.

    Again, only .gif, .jpg, .jpeg and .png extensions are allowed to be attached. Not able to attach .doc/.docx or .zip extensions.
  5. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 06 Jan Link to this post

    Hello Kartik,

    I tested the same locally—pasting text with Times New Roman font—, but to no avail. The text is pasted with the correct font. You can see that in this screencast—http://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx.

    As for sharing the file. You can try using a free cloud service to provide the file, like Dropbox, OneDrive, etc.

    Regards,
    Ianko
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  6. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 06 Jan Link to this post

    Hi,

    Sorry for the wrong link. Here you are the screencast—http://screencast.com/t/kcOJcmYNI.

    Regards,
    Ianko
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  7. kartik
    kartik avatar
    11 posts
    Member since:
    Jun 2014

    Posted 06 Jan in reply to Ianko Link to this post

    Hi Linko,
    Thanks for the response.

    I agree this is working fine in normal scenario but i am having trouble with few documents.
    Please check this Test Document to generate this issue. Font family of first line of the document is getting changed.

     

     

     

  8. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 06 Jan Link to this post

    Hi,

    It seems to me that the Styles repository of this document is quite messed up. Check out this screencast to see how you can possibly resolve this—http://screencast.com/t/rJNrXfDITa.

    You can also compare with the styles from a new document.

    Regards,
    Ianko
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017