Editor Image Manager throws 500 Error behind ISA Server

2 posts, 0 answers
  1. Pablo
    Pablo avatar
    10 posts
    Member since:
    Oct 2012

    Posted 30 Nov 2011 Link to this post

    I have a radeditor as follows:

    <telerik:RadEditor ID="Editor" runat="server" >
                        <Content>
                        
                        </Content>
                        <ImageManager DeletePaths="~/Images/EmailImages" UploadPaths="~/Images/EmailImages" ViewPaths="~/Images/EmailImages" />
                    </telerik:RadEditor>


    The image editor works great when the site is accessed from local network; however, when accessed from the internet, the radeditor  works, but NOT the IMAGE editor. It shows the error attached "Error Code: 500 Internal Server Error. The request was rejected by the HTTP filter". Doing further research, I found out that the http filter is done by the ISA server which is in fact my case. The IIS server is sitting behind an ISA Server. Somebody was having a similar issue with the radspell here: http://www.telerik.com/community/forums/aspnet/spell/isa-server-2004-and-radspell.aspx. Thus, I'd like to know if there is a work around for the image editor to avoid http filter (most likely the "Verify Normalization" http filter)

    Thanks


  2. Pablo
    Pablo avatar
    10 posts
    Member since:
    Oct 2012

    Posted 01 Dec 2011 Link to this post

    The problem is that ISA Server blocks requests whose query string contains ascii characters with code greater than 128. This is a default http filter from ISA Server called "block high bit characters" (http://technet.microsoft.com/en-us/library/cc302627.aspx). So, basically I was actually using a localization setting for spanish for the RadEditor as follows:

    <telerik:RadEditor ID="Editor" runat="server" BackColor="White" 
                        Language="es-ES" LocalizationPath="~/App_GlobalResources/es-ES/" 
                        ContentAreaMode="Div">
                        <Content></Content>
                        <ImageManager DeletePaths="~/Images/EmailImages" UploadPaths="~/Images/EmailImages" ViewPaths="~/Images/EmailImages" />
                    </telerik:RadEditor>


    It turns out that the query string for the dialog handler for the ImageManager had ascii codes above 128 as shown in the word "imágenes", specifically the letter á

    Telerik.Web.UI.DialogHandler.aspxDialogName=ImageManager&UseRSM=true&Skin=Default&Title=Manejador%20de%20imágenes


    The solution to this problem was to go to open up the "RadEditor.Tools.es-ES.resx" under the "App_GlobalResources" folder in your solution. Then replace the value"Manejador de Imágenes" with "Manejador de Imagenes" for the "ImageManager" string as shown in the attachment. Notice that there is no tilde in the letter a. You may want to do this in the rest of localization resources if you are experiencing requests being blocked by ISA Server. 

    After this change everything worked because the query string no longer passed ascii characters with codes greater than 128

    Telerik.Web.UI.DialogHandler.aspxDialogName=ImageManager&UseRSM=true&Skin=Default&Title=Manejador%20de%20imagenes

    Thanks



  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top