EditModes setting ignored in page layouts

5 posts, 0 answers
  1. Martin
    Martin avatar
    6 posts
    Member since:
    Oct 2009

    Posted 20 Apr 2010 Link to this post

    Dear Telerik team,

    I am using the following setting in both ConfigFile.xml and ListConfigFile.xml:

    <property name="EditModes">Design,Html</property>

    This works well in lists and RadEditor Web Parts. However, in page layouts (e.g. in the "Page Content" field, which is of type "Publishing HTML"), this settings seems to be ignored. It always displays "Design" and "Preview". See screenshots, which were taken from the same page.

    I'm using version 5.62 (01/15/2010) (2009.3.1314) on MOSS 2007

    Any idea?
  2. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 20 Apr 2010 Link to this post

    Hello Martin,

    Could you provide me with the contest of your ConfigFile.xml and ListConfigFile.xml files? I will use them in order to try reproducing the issue on our test server.


    Regards,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.

  3. Martin
    Martin avatar
    6 posts
    Member since:
    Oct 2009

    Posted 20 Apr 2010 Link to this post

    Here it is. I have verified both files are 100% identical.

    <?xml version="1.0" encoding="utf-8" ?>
    <!-- ==============================================================================================
     Config File valid structure:
     <configuration>
        <property>...</property>
        ...
      <property>
       <item>...</item>
       <item>...</item>
       ...
      </property>
      ...
     </configuration>
    =============================================================================================== -->
    <configuration>
     <property name="NewLineBr">true</property>
     <property name="TableLayoutCssFile">/_layouts/STYLES/Custom/TableDesigns.css</property>
     <property name="UseSharedToolbar">false</property>
     <property name="EditModes">Design,Html</property>
     <property name="ToolbarMode">ShowOnFocus</property>
     <property name="Height">360px</property>
     <property name="Width">680px</property>
     <property name="ExternalDialogsPath">/_wpresources/RadEditorSharePoint/5.6.2.0__1f131a624888eeed/Resources</property>
    </configuration>
  4. Martin
    Martin avatar
    6 posts
    Member since:
    Oct 2009

    Posted 20 Apr 2010 Link to this post

    I found the cause myself.

    The control itself was configured so it wouldn't allow HTML editing, as follows:

    <PublishingWebControls:RichHtmlField FieldName="PublishingPageContent" runat="server" id="RichHtmlField1" AllowHtmlSourceEditing="False"></PublishingWebControls:RichHtmlField>

    So setting AllowHtmlSourceEditing="True" fixed the problem.

    What's confusing, however, is the fact that the "Preview" tab was displayed instead of the HTML tab, so you might want to look into that.

    Best,
    Martin
  5. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 20 Apr 2010 Link to this post

    Hi Martin,

    Thank you for the provided information. I will log this in our bug-tracking system.

    Best wishes,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top