e.preventDefault() doesn't prevent the scheduler from performing read() with server filtering enabled

3 posts, 0 answers
  1. Devin
    Devin avatar
    8 posts
    Member since:
    Dec 2015

    Posted 14 Jul Link to this post

    I have a scheduler using a remote datasource with serverFiltering set to true. On the edit event, I call e.preventDefault() to keep the scheduler from going into edit mode so that I can handle the editing on a different page. Unfortunately something is calling my datasource's read() function even though it isn't necessary. It appears that I have no way prevent the read while editing an event with serverFiltering enabled. Is there a way to prevent the read from happening?
  2. Vladimir Iliev
    Vladimir Iliev avatar
    2156 posts

    Posted 18 Jul Link to this post

    Hello Devin,

    I tried to reproduce this behavior on our side but to no avail - the "read" operation is not called when preventing this event. Could you please create small demo in Kendo UI Dojo which to reproduce the issue and send it back to us for further investigation?

    Vladimir Iliev
    Telerik by Progress
    Get started with Kendo UI in days. Online training courses help you quickly implement components into your apps.
  3. Devin
    Devin avatar
    8 posts
    Member since:
    Dec 2015

    Posted 18 Jul in reply to Vladimir Iliev Link to this post

    I found the issue. Thank you for looking into this.
Back to Top