Drop down menu won't drop

5 posts, 0 answers
  1. Richard
    Richard avatar
    3 posts
    Member since:
    May 2008

    Posted 30 May 2008 Link to this post

    I'm using a RadToolbar with a RadToolbarDropDown. The DropDown menu has several menu items to allow the user to Export the grid in different formats. The first time I click it to export the grid it works fine. The next time (right after) I click on the RadToolbarDropDown nothing happens. The DropDown menu doesn't drop. I'm not posting back and performing all the export in client side code. I thought at first it was the RadAjaxManager but I've since disabled it just to narrow it down.

    Anyone else find this and have a workaround?

    Thanks,

    Richard.
  2. Peter
    Admin
    Peter avatar
    6637 posts

    Posted 30 May 2008 Link to this post

    Hello Richard,

    This is a known issue, and until we fix it, you can use this KB article as a workaround.

    All the best,
    Peter
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Richard
    Richard avatar
    3 posts
    Member since:
    May 2008

    Posted 30 May 2008 Link to this post

    Thanks Peter for the quick response. That did the trick!

    Regards,

    Richard.
  4. Richard
    Richard avatar
    3 posts
    Member since:
    May 2008

    Posted 30 May 2008 Link to this post

    Next question: Is there anything I need to do in order to enable Ajax on the toolbar and still have the ability to Export? If I turn on Ajax then the Export no longer works. I'm exporting from the clientside so I wouldn't think Ajax would interfere.

    Thanks,

    Richard.
  5. Peter
    Admin
    Peter avatar
    6637 posts

    Posted 30 May 2008 Link to this post

    Hello Richard,

    You need to do a real postback for the export button. This kb article will provide you with a solution.


    Peter
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Back to Top