Drawer double animation

5 posts, 1 answers
  1. CORNEL
    CORNEL avatar
    44 posts
    Member since:
    Jan 2012

    Posted 27 Mar 2014 Link to this post

    Hi Guys!

    Since i have upgraded to latest kendo version 2014.1.318 i have noticed on Safari iOS 6.X that every time i open a view from drawer it experiences a double animation of the view. First the view is shown instantly once is loaded and then again the view is shown with a sliding animation. The behavior can also be reproduce on kendo drawer demo sample and on real world web app with more complex views and higher request latency it is even more pronounced. I have also tried setting the Application transition to none and also set transition to none for each view opened from drawer but to no avail, the double animation effect is still experienced. 
    I have not experienced this scenario in previous kendo version 2013.3.1324 and as this effect is quite noticeable and affects end user experience i would like to know if it is a known issue and if there is any fix available?

    Cheers! 

  2. Answer
    Petyo
    Admin
    Petyo avatar
    2439 posts

    Posted 28 Mar 2014 Link to this post

    Hi,

    Thank you for bringing this to our attention - indeed, this is a regression we have slipped into the new release. It does not happen every time, most probably this is why it has passed QA. I have logged this as a bug in our system - We are going to look into addressing it and release an internal build which fixes it. 

    I am updating your telerik points for your assistance. 

    Regards,
    Petyo
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
  3. Kendo UI is VS 2017 Ready
  4. Mirko
    Mirko avatar
    5 posts
    Member since:
    Mar 2014

    Posted 13 Feb 2015 in reply to Petyo Link to this post

    Is there any news regarding this issue? I am still having this problem in Kendo UI v2014.3.1119.
  5. Petyo
    Admin
    Petyo avatar
    2439 posts

    Posted 17 Feb 2015 Link to this post

    Hi Mirko,

    most likely, the problem you are facing is this one (check the note)


    Regards,
    Petyo
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
  6. Mirko
    Mirko avatar
    5 posts
    Member since:
    Mar 2014

    Posted 17 Feb 2015 Link to this post

    Thank you for the tip about disabling transitions. It indeed solved my problem.

    At first I was a bit confused because I never actually enabled transitions and it even worked the first time. I recreated the issue here. After that I added a bunch of data-transition="none" and now it works.
Back to Top
Kendo UI is VS 2017 Ready