DragInfo fires after Select in GridView Since Q2 Release

2 posts, 0 answers
  1. Daniel Walton
    Daniel Walton avatar
    18 posts
    Member since:
    Feb 2010

    Posted 30 Jul 2010 Link to this post

    I have build a large project with several pages, gridviews, and DragDropManagers. With the Q1 (SL4) release, I could set multiselect=Extended on a gridview, wire up the Drag and Drop events, and be able to select multiple rows, then click on ANY PART of the selection to start dragging the group. Now, with the Q2 release (even in 0723 build) If I select multiple rows, then click on the selection to drag, instead the select event fires and the row I dragged from is now the only selected row. I can circumvent the new undesired behavior by grabbing a checkbox in a GridViewSelectColumn, but I would like to fix this issue for my users. You can observe the same issue in the rightmost listbox in the demo application at http://demos.telerik.com/silverlight/#DragAndDrop/TreeToGrid.

  2. Tsvyatko
    Tsvyatko avatar
    832 posts

    Posted 02 Aug 2010 Link to this post

    Hello Daniel Walton,

    Please check our latest internal build (30.07) where this issue has been resolved and let me know if it works as expected.

    Please excuse us for any inconvenience caused.

    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft banner
Back to Top