Drag & Drop Position not visible between on-demand nodes.

5 posts, 0 answers
  1. MOHIT
    MOHIT avatar
    3 posts
    Member since:
    Apr 2014

    Posted 29 Apr 2014 Link to this post

    Hello,

    I am currently using a RadTreeView that loads all parent nodes in collapsed mode but its child nodes on demand. 

    When we expand any parent node, then drag any child node we face an issue -> Position line(visual pointer) is not displayed that determines where will be the draged node placed. Thereafter it works fine.
    Issue occurs only for the first time.

    Please advise.

    Regards,
    Mohit
  2. Boyan Dimitrov
    Admin
    Boyan Dimitrov avatar
    1746 posts

    Posted 02 May 2014 Link to this post

    Hello Mohit,

    I would like to clarify that we are not aware of such problem with dragging and dropping RadTreeView nodes between the RadTreeView nodes. The line indicating where the node will be dropped at this moment works fine as you can see in this video. In this video the dropping functionality is not implemented so the node is actually not moved to the position where I dropped it. This demo shows how you can implement this functionality. Could you please elaborate a bit more on your scenario so we can understand in detail the problem you are facing?

    Regards,
    Boyan Dimitrov
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. MOHIT
    MOHIT avatar
    3 posts
    Member since:
    Apr 2014

    Posted 05 May 2014 in reply to Boyan Dimitrov Link to this post

    Hi Boyan,

    I have sent you a video link for the same issue which i had mentioned.
    In this video you will see that when for the first time i drag any value & want to place it between other two values then Position line(visual pointer) is not displayed & it undergoes to any value .
    But yes if i again place that value into the tree node & again drag that node & want to place between any two nodes then Position line(visual pointer) is displayed.
    Issue exists only for the first time.
    Please have a look at this video with respect to the above mentioned comments & kindly suggest. 
    Link - https://www.youtube.com/watch?v=G2ZD7Y1obRA&feature=youtu.be

    Thanks
    Mohit Tevatia




  5. Boyan Dimitrov
    Admin
    Boyan Dimitrov avatar
    1746 posts

    Posted 07 May 2014 Link to this post

    Hello Mohit,

    Indeed on the video the line that shows the drop node location is not shown the first time when user drags and drops nodes between the RadTreeView. In order to investigate that problem we would need a sample page that replicates this problem. Could you please open a support thread and attach a page that reproduces this issue. Please note that you
    can populate the RadTreeView with dummy data  in order to avoid sending your own data.


    Regards,
    Boyan Dimitrov
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  6. MOHIT
    MOHIT avatar
    3 posts
    Member since:
    Apr 2014

    Posted 13 May 2014 in reply to Boyan Dimitrov Link to this post

    Hi Boyan,

    I have resolved this issue using your forum posts & related suggestion.
    Thanks for the reply.

    Mohit Tevatia
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017