Drag & drop shows only "Drop before..." in IE8, WinXP

2 posts, 0 answers
  1. David Walton
    David Walton avatar
    6 posts
    Member since:
    Sep 2009

    Posted 15 Sep 2010 Link to this post


    I'm having an interesting issue where a Telerik control works exactly as expected in Windows 7 & OSX across all major browsers & in XP (in Firefox, at least).  However, starting today or yesterday, in IE8, WinXP, the drop target mouse-over text displays "Drop before..." across the entire length of the object (as opposed to the standard 25/50/25 split of Before, In, and After).  Dropping causes the item to be inserted before the item hovered.

    What confuses me is that nothing changed in the individual's environment (to my knowledge) nor has the Silverlight app itself changed.

    Is there any known issue regarding drag/drop/hit-targeting in IE8/WinXP or with this control in general?  I searched the forums and haven't found any similar complaint- it wasn't until I saw the bug with my own eyes that I even believed it was occurring.


    Thanks much!!
  2. Vladislav
    Vladislav avatar
    274 posts

    Posted 20 Sep 2010 Link to this post

    Hi David Walton,

    Thank you for this report.
    Unfortunately we wasn't able to reproduce the described issue on our demo.
    We tested it with Windows XP SP3, IE 8 (8.0.6001.18702) and SL plug-in version 4.0.50826.0 and it is working as expected. Can you please share with us your version of the above?
    Can you please try to reproduce it in our online demo?

    If you encounter this problem on your own project it will be really helpful if you can send us your project in order to identify the problem.

    Thank you in advance.

    Sincerely yours,
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft banner
Back to Top