Double XHR call on remote view request (tabstrip)

4 posts, 0 answers
  1. M
    M avatar
    1 posts
    Member since:
    Feb 2012

    Posted 23 Mar 2012 Link to this post

    I have a tabstrip with 7 icons that all request for a remote view when clicked.
    On response the views content is show but without rendering the header/footer properly.
    I have found out that on click of a tab each remote view is called twice (xhr) and returned twice.
    Anyone had the same issue?
  2. Hakan
    Hakan avatar
    1 posts
    Member since:
    May 2012

    Posted 16 May 2012 Link to this post

    i have same problem. i cant load remote content with tabstrip. when i load it tabstrip disapear. it would be nice if there is an example of it.

    edit:
    when tabstrip disapear, i go back and hit the tabstrip button again then tabstrip didnt disapear
  3. Kendo UI is VS 2017 Ready
  4. Eyal
    Eyal avatar
    2 posts
    Member since:
    Jan 2013

    Posted 17 Jan 2013 Link to this post

    Same issue here.
    Was this resolved?
  5. Alexander Valchev
    Admin
    Alexander Valchev avatar
    2875 posts

    Posted 22 Jan 2013 Link to this post

    Hello guys,

    I am not sure exactly where the problem comes from - you did not shared any code that demonstrates your implementation. As an assumption, the problem might be caused by multiple initialization of the mobile application. Please make sure that the application is initialized only once in the index page.

    In the attachments you will find a working sample that demonstrates such scenario.

    Regards,
    Alexander Valchev
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
Back to Top
Kendo UI is VS 2017 Ready