Does cut and paste work on Mac OS X ?

11 posts, 0 answers
  1. Jonx
    Jonx avatar
    258 posts
    Member since:
    Jul 2012

    Posted 01 Sep 2010 Link to this post

    Hello,
    I would like to know if the cut and paste feature is meant to work on Mac OS X also...
    I tried on several machines, the silverlight application is running correctly, just nothing happens when I paste in my grid.
    It works perfectly on my windows 7 PC.

    I'm cuting from Excel 2008...

    I'm suck as I work on windows but my clients are on mac os... 10.5.8 and up...

    Any hints on that?
    Thank you,
    John.
  2. Konstantina
    Admin
    Konstantina avatar
    2332 posts

    Posted 03 Sep 2010 Link to this post

    Hello John,

    Thank you for contacting us.

    Cut and paste feature is working on MAC OS. Could you please give us some more details about your application. If you could try to reproduce the issue in a sample project and send it to us it will be very helpful.

    Looking forward to your reply.

    All the best,
    Konstantina
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft banner
  4. Jonx
    Jonx avatar
    258 posts
    Member since:
    Jul 2012

    Posted 03 Sep 2010 Link to this post

    Hello Konstantina,
    Thank you for looking into this...

    I gave it another try. It's my client reporting that it was not working.
    The thing is the following...

    On a mac computer, cut and paste is working with Apple + C Apple + V combinations...

    What is sure in my grid is that Apple + V does not paste anything...

    What IS pasting something is Ctrl + C, when I tried that it did open the cut and paste authorisation dialog, I did confirm and not it pasting something.

    I say something because it does not do the same then on my PC.

    On my PC, I do Ctrl + C on 3 rows and 4 columns in a excel 2007 spreadsheet. The 4th column is empty.

    [ data1 ][ data2 ][ data3 ][ empty ]
    [ data4 ][ data5 ][ data6 ][ empty ]
    [ data7 ][ data8 ][ data9 ][ empty ]

    I go to my grid, click into it. Then press CTRL + V.
    The grid has 4 columns.

    It does pasted the 3 lines like expected and does skip the empty cell.
    I get exactly the same data pasted in my grid cells.

    On the apple computer...
    Apple + V does not paste anything. This should as it is the standard way of pasting things on a apple computer.
    What shortcut do you handle?

    It seems to me that you handle the same shortcut then on a PC: Ctrl + V, can you confim that?

    Then, on my mac, when I do Ctrl + V instead of getting exactly the same then on my PC, I get only one line filled with data.
    I get that in the resulting grid:

    [ data1 ][ data2 ][ data3 ][ data4 ]

    I does ignore the empty cell and the multi lines...
    I know there is a skip cells paste mode on the grid. I do not use that mode...

    Can you confirm that on mac you are using Ctrl + V and not Apple + V to handlle the paste (maybe this is an issue with the plugin), what shortcut do you use to paste something in a grid?

    Can you try to paste a line that contains empty cells?

    Can you paste multi lines in the same operation?

    If this is all working for you I will try to trim down my project to build a sample to reproduce my problem.

    Thank you for your help...

    John.

    ps: I have another thread open because I have weird issues on mac:
    http://www.telerik.com/community/forums/silverlight/menu/drag-and-group-of-column-gridview-column-headers-does-not-work-oob-on-mac-os-x.aspx#1333261



  5. Yavor Georgiev
    Admin
    Yavor Georgiev avatar
    982 posts

    Posted 03 Sep 2010 Link to this post

    Hi John,

     I'm moving this thread to the RadGridView for Silverlight forum.

     This is an elusive issue which we have sometimes been able to reproduce on in our tests on a couple of 10.6 machines. However, you are the first client to report this issue and thus we will resume our investigations into the issue.

    Greetings,
    Yavor Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Jonx
    Jonx avatar
    258 posts
    Member since:
    Jul 2012

    Posted 03 Sep 2010 Link to this post

    Excellent. Terrific support like always ;)

    Can you confirm that the paste shortcut you expect is CTRL + V?

    Is this an issue with your controls or an issue with the silverlight plugin?

    I guess the latest... Any work around? As it seem that the plugin only requires clipboard access when you use CTRL + C or CTRL + V...

    I can confirm that I have the exact same issue on both the mac laptops I have access to:

    paste with Ctrl + V
    missing empty cells and only one line...

    I have this on one older macbook icore 2 duo 10.5.8 and on a new mac book pro icore 7, 10.6.4

    Both using the latest SL4 update from yesterday...

    I you need me to test a solution... Let me know,
    Thanks a lot in advance,
    John.

    edit: on windows 7 (US) I copy from excel 2007 (US) and on apple OSX (FR) from excel 2008 (FR) don't know if it's important.
  7. Yavor Georgiev
    Admin
    Yavor Georgiev avatar
    982 posts

    Posted 03 Sep 2010 Link to this post

    Hi John,

     Yes, right now copy/paste is activated using Control + C / Control + V instead of Command + C / Command + V. We will fix that for next week's Internal Release.

    Best wishes,
    Yavor Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Jonx
    Jonx avatar
    258 posts
    Member since:
    Jul 2012

    Posted 03 Sep 2010 Link to this post

    Will I be able to get access to that build?

    Also, can you reproduce the missing lines problem or shall I build a sample showing the problem (will take some time)?

    Thank you :)
  9. Yavor Georgiev
    Admin
    Yavor Georgiev avatar
    982 posts

    Posted 03 Sep 2010 Link to this post

    Hello John,

     All of your clients with active subscriptions have access to our Internal Builds. In short, yes.

     We will try to replicate the issue, but if we cannot, then a repro project would be very welcome. Thank you for your cooperation and eagerness. I will let you know when any developments on this issue occur.

    Greetings,
    Yavor Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Jonx
    Jonx avatar
    258 posts
    Member since:
    Jul 2012

    Posted 03 Sep 2010 Link to this post

    No problem, it's in my interest after all ;)
    Let me know, thanks...
  11. Jonx
    Jonx avatar
    258 posts
    Member since:
    Jul 2012

    Posted 06 Sep 2010 Link to this post

    Yavor? Just to be sure... Shall I open a case on the support when I have problems like that?
    Or is the forum first, the right way to do it?

    For exemple here, shall I open a case on the support to be sure to get some follow up?

    I'm new here, so I'm still not sure about the correct usages...

    !thanks for letting me know,
    John.
  12. Yavor Georgiev
    Admin
    Yavor Georgiev avatar
    982 posts

    Posted 06 Sep 2010 Link to this post

    Hello John,

     You don't need to open a separate support ticket.

    Greetings,
    Yavor Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top
DevCraft banner