Document needs WSS compatible application

2 posts, 0 answers
  1. rachna
    rachna avatar
    6 posts
    Member since:
    Jan 2008

    Posted 11 Jan 2008 Link to this post

    Hi there
    I was able to make the RadEditor the default editor in my sharepoint site, however, while adding a new document to a document library or editing an existing document which I created externally through word 2007, it complains with the error below:
    New Document requires a Windows Sharepoint Services-sompatible application and Internet explorer 6.0 or greater.

    I followed the support article on microsoft and they suggest installing sharepoint support as well as re-registering the Owssupp.dll file. I did the former successfully however, the dll unreg and reg fails.

    This problem started only after integrating the radeditor with Sharepoint.

    How do I get around using the radeditor to submit new content to a document library in sparepoint? Does it have anything to do with enabling the word 2007 template since I do not see it by defauly in the document template drop down list.


    Rachna Khune
    SDE - Microsoft
  2. Lini
    Lini avatar
    2144 posts

    Posted 18 Jan 2008 Link to this post


    Does the error happen when you upload a document from one of the editor's dialogs or when you are browsing the Document library directly in the browser? I am not exactly sure how to reproduce this scenario on the server here.

    All the best,
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center

Back to Top