Do not use in conjunction with the SL Toolkit for WP TransitionFrame

6 posts, 0 answers
  1. Simon
    Simon avatar
    52 posts
    Member since:
    Jun 2010

    Posted 21 Mar 2012 Link to this post

    There is a known issue with the Telerik Dialog service if the RootFrame type of your application is using the Transition Frame object from the Silverlight Toolkit for Windows Phone.

    This causes the Dialogs used by the Rate Reminder to appear feint and masked (not very readable)

    To resolve this either set the root frame back to a PhoneApplicationPage or replace it with the RadPhoneApplicationFrame
    instead.
  2. Tiziano
    Tiziano avatar
    17 posts
    Member since:
    Feb 2012

    Posted 03 Apr 2012 Link to this post

    Yeah same problem here!
    Then used the RadPhoneApplicationFrame, but with there is a problem with toolkit datepicker and listpicker.
    Solved with raddatepicker and radlistpicker :)
  3. DevCraft banner
  4. Simon
    Simon avatar
    52 posts
    Member since:
    Jun 2010

    Posted 15 Apr 2012 Link to this post

    I think it goes so far to chose a framework and stick with it, don't mix the SL Toolkit and Telerik, just use one or the other.
  5. Ryan
    Ryan avatar
    5 posts
    Member since:
    Oct 2011

    Posted 07 Mar 2013 Link to this post

    This is a pretty old thread, but in case anyone finds it useful, you can actually use the WP Toolkit TransitionFrame with the Telerik RadRateApplicationReminder. To do this, you need to explicitly set the Foreground and Fontsize when creating the TransitionFrame. For example:

    this.RootFrame = new TransitionFrame()
    {
        Foreground = (Brush)this.Resources["PhoneForegroundBrush"],
        FontSize = (double)this.Resources["PhoneFontSizeNormal"],
    };

    Hope this helps!

    Ryan
  6. Dharm
    Dharm avatar
    2 posts
    Member since:
    Jun 2011

    Posted 04 Jun 2015 Link to this post

    I have the exact same symptoms - the rating reminder dialog is faded and cant be seen (only when phone theme is white; works fine when phone theme is black).

    But I am not using any Transition Frame object in my root frame. My rootframe is set to PhoneApplicationPage 

    Any idea how I can resolve it?

  7. Dharm
    Dharm avatar
    2 posts
    Member since:
    Jun 2011

    Posted 04 Jun 2015 in reply to Dharm Link to this post

    My lib version is 2013.3.1317.3040
Back to Top
DevCraft banner