Disabling scrollbars for the HTMLPlaceHolder

4 posts, 0 answers
  1. mc2000
    mc2000 avatar
    48 posts
    Member since:
    Nov 2009

    Posted 13 Aug 2010 Link to this post

    I have the HTMLPlaceHolder and I would like it to not show scrollbars (basically working like an overflow:hidden). I tried:
    (RotatorContent.HtmlPresenter.Children[0] as HtmlElement).SetStyleAttribute("overflow", "hidden");
    as well as setting the scrollbar.visibility to hidden. How can I acheive this?
  2. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 18 Aug 2010 Link to this post

    Hello mc2000,

    Can you try setting the iframe scrolling attribute instead, like so:
    HtmlElement iframe = (HtmlElement)myHtmlPlaceHolder.HtmlPresenter.Children[0];
    iframe.SetAttribute("scrolling", "no");

    Give it a try and let me know if it works for you or if you need more info.

    Greetings,
    Tina Stancheva
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft banner
  4. ss
    ss avatar
    50 posts
    Member since:
    Jun 2010

    Posted 26 Oct 2010 Link to this post

    I need to diable scrollbars too but following solution doesnt work.

    1.RadHtmlPlaceholder htmlPlaceholder = new RadHtmlPlaceholder();
    2.HtmlElement iframe = (HtmlElement)htmlPlaceholder.HtmlPresenter.Children[0];
    3.iframe.SetAttribute("scrolling", "no");

    iframe.TagName = "div"

    Can you please help me.

    Thank you.

  5. Kiril Stanoev
    Admin
    Kiril Stanoev avatar
    1511 posts

    Posted 28 Oct 2010 Link to this post

    Hi ss,

    Have you tried setting ScrollViewer.HorizontalScrollBarVisibility="Disabled" and ScrollViewer.VerticalScrollBarVisibility="Disabled"?

    <telerik:RadHtmlPlaceholder ScrollViewer.HorizontalScrollBarVisibility="Disabled"
            ScrollViewer.VerticalScrollBarVisibility="Disabled" />

    If this doesn't help could you please send us a project reproducing the issue. We'd be glad to further assist you.

    Sincerely yours,
    Kiril Stanoev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top