Disabling animations on RadContextMenu sub-menus

3 posts, 0 answers
  1. Jose
    Jose avatar
    3 posts
    Member since:
    Sep 2012

    Posted 04 Apr 2011 Link to this post

    Is there a way to disable the slide animations when expanding sub-menus in a RadContextMenu?

    Thanks,
    Jose
  2. Dani
    Admin
    Dani avatar
    848 posts

    Posted 07 Apr 2011 Link to this post

    Hello Jose,

    The AnimationManager is responsible for animations in RadControls. Please, try to disabled animations as follows:

    <telerik:RadContextMenu x:Name="contextmenu" telerik:AnimationManager.IsAnimationEnabled="False" />

    Alternatively, you could also try setting the AnimationSelector to null in the code-behind:

    AnimationManager.SetAnimationSelector(this.contextmenu, null);


    I hope this helps.

    All the best,
    Dani
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. UI for WPF is Visual Studio 2017 Ready
  4. Jose
    Jose avatar
    3 posts
    Member since:
    Sep 2012

    Posted 07 Apr 2011 Link to this post

    The first option didn't work for me but the second alternative (nulling the animation selector) is good enough.  Thanks!
Back to Top