Disabling alt-gr hotkey function

6 posts, 0 answers
  1. Joel Sanderi
    Joel Sanderi avatar
    10 posts
    Member since:
    May 2008

    Posted 20 Oct 2008 Link to this post

    Hello!

    Whenever I press the alt-gr sign in a control that belongs to a radribbonbar, the shortcut-menu with numbers are shown, which is an intersting feature. However, if I'm for example in a propertygrid and want to type something that requires the alt-gr button to be pressed (e.g. $,@,€ and £ on my swedish keyboard layout), it will make the propertygrid lose focus and I have to click it again to continue writing.

    How do I solve this the easiest way, is it possible to disable the hotkey-function?

    Best Regards, 

    Joel Sanderi
  2. Nick
    Admin
    Nick avatar
    767 posts

    Posted 21 Oct 2008 Link to this post

    Hello Joel Sanderi,

    Thank you for contacting us.

    Your case made us do some tests with non-US localization settings and I have to agree that our tool does not behave promptly. We will consider increasing the delay which we have to show the key maps. Currently, I would suggest to set the EnableKeyMap property to false. This will disable the keymap feature.  

    Do not hesitate to contact me if you have further questions.
     

    Sincerely yours,
    Nick
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. UI for WinForms is Visual Studio 2017 Ready
  4. Joel Sanderi
    Joel Sanderi avatar
    10 posts
    Member since:
    May 2008

    Posted 23 Oct 2008 Link to this post

    Hello, thanks for your support in this matter.

    I had to double-check this, but the RadRibbonBar already has its property EnableKeyMap set to false.

    Do I have to edit any other controls or properties?

    Thanks in advance, 

    Joel
  5. Nick
    Admin
    Nick avatar
    767 posts

    Posted 23 Oct 2008 Link to this post

    Hello Joel Sanderi,

    It should be just that - turn off the KeyMap feature.

    Please see the sample application that is attached. Do you experience any problem with it and is this the case you are reviewing? 

    Do not hesitate to contact me back if you have further questions.

    All the best,
    Nick
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  6. Arul S V
    Arul S V avatar
    21 posts
    Member since:
    Mar 2010

    Posted 21 Apr 2010 Link to this post

    How to set the EnableKeyMap false to a RadButton. This is not working for a RadButton.

    Note:
    Shortcut key should work when i press a Alt+Key.

     

  7. Nikolay
    Admin
    Nikolay avatar
    1803 posts

    Posted 27 Apr 2010 Link to this post

    Hello Arul S V,

    Please refer to the following forum thread that concerns the process of assigning a shortcut to RadButton:
    http://www.telerik.com/community/forums/winforms/general-discussions/shortcuts-problem-inconsistent-behaviour.aspx

    Sincerely yours,
    Nikolay
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top
UI for WinForms is Visual Studio 2017 Ready