Disabled Toolbar Button Fires Click Event

2 posts, 0 answers
  1. Sean
    Sean avatar
    79 posts
    Member since:
    May 2007

    Posted 17 Feb 2015 Link to this post

    I believe I have found a bug with the Toolbar widget.  If I disable a button in the Toolbar, it is greyed out and clicking on the button does nothing.  However, if the window is resized and the button is moved to the overflow section (the hamburger menu), it will appear greyed out, but clicking on it will fire the associated click event handler.

    I am using the Q3 2014 SP2 release of Kendo, and I see this behavior in Chrome as well as Internet Explorer 11.  You can see the behavior here: http://dojo.telerik.com/iSajA/3.  Run the sample, and click the "Click Me" button when it is visible in the main toolbar - the click handler will not fire.  However, when you resize the window to force "Click Me" to the overflow menu, the click event will fire, even though the button is disabled.

    Please let me know if there is a workaround, or if a fix will be coming for this.

    Thanks,
    Sean
  2. Petyo
    Admin
    Petyo avatar
    2439 posts

    Posted 19 Feb 2015 Link to this post

    Hello Sean,

    this is a bug indeed, I am logging it here. We are going to investigate it, and resolve it in one of our next internal builds. You may subscribe to the issue for more details.  

    Regards,
    Petyo
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
  3. Kendo UI is VS 2017 Ready
Back to Top