Disable RadPaginationControl Horizontal scroller

5 posts, 0 answers
  1. Tareq
    Tareq avatar
    36 posts
    Member since:
    Jun 2011

    Posted 04 Apr 2012 Link to this post

    Hi,

    I tried to disable the RadPaginationControl Horizontal scrollviewer like this:
    <telerikPrimitives:RadPaginationControl PageProvider="{Binding ElementName=slideView}"
                                          DisplayMode="Thumbnails"
                                          ItemTemplate="{StaticResource dot}"  ScrollViewer.HorizontalScrollBarVisibility="Disabled"
                                          CurrentItemTemplate="{StaticResource dotFilled}"
                                          x:Name="pagination"
                                          BorderThickness="0,0,0,1"
                                          BorderBrush="{StaticResource highlightBrush}"
                                          Margin="12,-12,0,0">
                    </telerikPrimitives:RadPaginationControl>

    but it didnt work, how can i disable the scroller of the dots?
  2. Todor
    Admin
    Todor avatar
    778 posts

    Posted 09 Apr 2012 Link to this post

    Hello Tareq,

    Thank you for contacting us.

    In the current version of RadPaginationControl you can't disable the scrolling. We are going to add it and you will be able to disable the scrolling when you download our next InternalBuild.

    I hope this information is useful. Let me know if you need additional assistance.

    Kind regards,
    Todor
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. DevCraft banner
  4. Todor
    Admin
    Todor avatar
    778 posts

    Posted 19 Apr 2012 Link to this post

    Hi Tareq,

    I want to apologize for the misleading information in my previous post. You can disable the scrolling of the thumbnails in the current version of RadPaginationControl. Since it is not the PaginationControl that is scrolling, but the thumbnail list, your approach is not correct. Instead, you should disable the scrolling through the ThumbnailListStyle property:

    <telerikPrimitives:RadPaginationControl.ThumbnailListStyle>
        <Style TargetType="telerikPagination:PaginationThumbnailListControl">
            <Setter Property="ScrollViewer.HorizontalScrollBarVisibility" Value="Disabled"/>
        </Style>
    </telerikPrimitives:RadPaginationControl.ThumbnailListStyle>

    Here telerikPagination is mapped to the clr-namespace Telerik.Windows.Controls.Pagination from the Primitives assembly.

    I hope this helps. Let me know if you need additional assistance.

    Kind regards,
    Todor
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  5. Tareq
    Tareq avatar
    36 posts
    Member since:
    Jun 2011

    Posted 23 Apr 2012 Link to this post

    Thanks for answering,

    But It didn't work for me, this is my code:
                        
    <telerikPrimitives:RadPaginationControl  Grid.Row="1" PageProvider="{Binding ElementName=slideView}"
                  DisplayMode="Thumbnails" Width="160"
                  ItemTemplate="{StaticResource dot}"
                  CurrentItemTemplate="{StaticResource dotFilled}"
                  x:Name="pagination"
                  BorderThickness="0,0,0,1"
                  Margin="12,-42,0,0">
        <telerikPrimitives:RadPaginationControl.ThumbnailListStyle>
            <Style TargetType="telerikPagination:PaginationThumbnailListControl">
                <Setter Property="ScrollViewer.HorizontalScrollBarVisibility" Value="Disabled"/>
            </Style>
        </telerikPrimitives:RadPaginationControl.ThumbnailListStyle>
    </telerikPrimitives:RadPaginationControl>

    the control still scrolls horizontally 
    can you help please?

  6. Todor
    Admin
    Todor avatar
    778 posts

    Posted 24 Apr 2012 Link to this post

    Hi Tareq,

    It is really strange that the scrolling is not disabled, because on our side everything works as expected. Could you please confirm that you have mapped the prefixes to the correct clr-namespaces:
    xmlns:telerikPagination="clr-namespace:Telerik.Windows.Controls.Pagination;assembly=Telerik.Windows.Controls.Primitives"
    xmlns:telerikPrimitives="clr-namespace:Telerik.Windows.Controls;assembly=Telerik.Windows.Controls.Primitives"

    If this doesn't help, I'd like to kindly ask you to open a new support ticket in order to be able to send us a project illustrating the issue because it seems that this code-snippet is not enough to resolve it.

    I'm looking forward to your response.

    Greetings,
    Todor
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

Back to Top
DevCraft banner