Disable CTRL+A shortcut

3 posts, 1 answers
  1. Nicolas
    Nicolas avatar
    57 posts
    Member since:
    Dec 2008

    Posted 05 Nov 2010 Link to this post

    Hi,

    I need to disable the CTRL+A shortcut on the TreeView (because the tree is virtualized and in our case it doesn't make sense to select all the items while they are not all loaded).

    How can this be achieved?

    Thanks
  2. Answer
    Hristo
    Admin
    Hristo avatar
    352 posts

    Posted 09 Nov 2010 Link to this post

    Hello Nicolas,

    The RadTreeView should not react when the CTRL+A is pressed. Meaning that CTRL+A is disabled by default. In fact you should implement the "Select All" command by your own. We decided not to handle that key combination due to many custom scenarios clients may require. In other hand it is really easy to implement that functionality by your own custom needs.

    Please let us know if you need more info or help about our products.

    Greetings,
    Hristo
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft banner
  4. Nicolas
    Nicolas avatar
    57 posts
    Member since:
    Dec 2008

    Posted 09 Nov 2010 Link to this post

    Hi Hristo,

    Thanks for the response.

    I just realized that I must have been confused when I wrote this because I was really thinking about the GridView and not the TreeView. I think I even did the research for the TreeView, so I'll search how to disable CTRL+A on the GridView and will post in the GridView forum if I am still facing issues.

    Sorry about this.
Back to Top