Designer hourglass

8 posts, 0 answers
  1. MiddleTommy
    MiddleTommy avatar
    163 posts
    Member since:
    Nov 2009

    Posted 16 Sep 2010 Link to this post

    I am experiencing a slow designer experience. After every edit ( resize, move, text edit, expression, format, style, etc...) the designer stops and throws the hourglass (if thats what you call it in win 7) mouse cursor. It takes about 10 seconds then the designer is ready for the next edit. It is very frustrating. It does this on new blank and existing complex reports. I know you cant really find the problem but is there any wisdom you guys have learned or things to look for? 
  2. MiddleTommy
    MiddleTommy avatar
    163 posts
    Member since:
    Nov 2009

    Posted 17 Sep 2010 Link to this post

    I am noticing the Error Window pops up after the hour glass stops and then goes away.
  3. MiddleTommy
    MiddleTommy avatar
    163 posts
    Member since:
    Nov 2009

    Posted 17 Sep 2010 Link to this post

    That error window got me thinking so I uninstalled JustCode as a test and the problem went away
  4. Blagoev
    Admin
    Blagoev avatar
    49 posts

    Posted 27 Sep 2010 Link to this post

    Hello MiddleTommy,

    Thanks for taking the effort reporting this problem. Can you please provide us with more details on what designer you experience these issues. Is it a Winforms designer or web or something else. What version of JustCode you are using. We have made a lot of fixes that will be part of our next release, especially performance ones, so you may not experience such problems anymore.

    Nevertheless ,please don't hesitate to contact us for these or other issues you may have.

    Regards,
    Blagoev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. MiddleTommy
    MiddleTommy avatar
    163 posts
    Member since:
    Nov 2009

    Posted 27 Sep 2010 Link to this post

    It is the visual studio Telerik Reporting designer. I was using the 2010.2.826.2 or 00753JustCode_2010.2.817_Dev version of JustCode.
    And the 00716Telerik_Reporting_Q2_2010_4_1_10_729_DEV Report Designer.
  6. Blagoev
    Admin
    Blagoev avatar
    49 posts

    Posted 05 Oct 2010 Link to this post

    Hi MiddleTommy,

    Thanks for the details. We will further investigate the problem. In the mean time if you continue to experience such issues you can try upgrading to a newer version of JustCode. We fixed a lot of performance problems in the later versions. There is also a service pack for the Telerik Reporting Designer which can help you not experience these issues.
    Thanks for spending time sending us this information.

    Best wishes,
    Blagoev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. David Yardy
    David Yardy avatar
    22 posts
    Member since:
    Aug 2007

    Posted 13 Feb in reply to Blagoev Link to this post

    We are having extremely slow performance when working in the report designer with the latest version with vs.net 2015 (i7 32gb ram cpu/processor).  how to improve vs.net-telerik report designer? (this is killing us right now)

    thx

  8. Svetlozar
    Admin
    Svetlozar avatar
    294 posts

    Posted 16 Feb Link to this post

    Hi,

    Do you have JustCode installed? If you do, does the issue go away if you disable JustCode from JustCode Menu | Help | Disable JustCode?

    Regards,
    Svetlozar
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top