Deploy Solution Error RadEditorMOSS.wsp

4 posts, 0 answers
  1. Patrick0103
    Patrick0103 avatar
    7 posts
    Member since:
    Jul 2004

    Posted 23 Dec 2008 Link to this post

    Hi~

    I have some problem while deploying radEditorMoss.wsp on SharePoint 2007 farm.
    Following installing instruction, i added the solution via stsadm.exe and then i checked it was completed.
    After then i tried to deploy the solution on SharePoint 3.0 Central Administration.
    However, it was not completed with following message:

    Deployment Status : Error
    Last Operation Result : Some of the files failed to copy during deployment of the solution.
    last Operation Details : testserver : http://testserver:45839/: SharePoint - 23152 : Error : The web.config is missing from this IIS Web Site : C:\Inetpub\wwwroot\wss\VirtualDirectiories\23152\web.config.

    so, i checked the path and i knew there is nothing on the path.

    How can i fix this problem?

    thanks for your  help.
    patrick.


  2. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 23 Dec 2008 Link to this post

    Hi Patrick,

    Try restarting the server and make sure that the SharePoint Administration service is running after the restart.

    If that does not work, try going to Central Administration > Operations > Global Configuration > Timer Job Definitions and see if you can remove the job from there.

    Before you try to deploy the solution again, delete the RadEditorSharePoint folder from the VS-MOSS machine (\Program Files\Common Files\Microsoft Shared\web server extensions\wpresources\RadEditorSharePoint).



    Regards,
    Stanimir
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.

  3. Patrick0103
    Patrick0103 avatar
    7 posts
    Member since:
    Jul 2004

    Posted 23 Dec 2008 Link to this post

    Dear Stanimir,

    Thanks for your quick reply but i have one thing that i cann't understand what you say.
    You said that as below:
             If that does not work, try going to Central Administration > Operations > Global Configuration > 
            Timer Job Definitions and see if   you can remove the job from there.

    There is many jobs. What do i see the job that i can remove?
    I can disable all of job in there but i cann't remove any one.

    Regards,
    Patrick.
  4. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 29 Dec 2008 Link to this post

    Hello Patrick,

    I think that you can cancel the deployment/retraction job with the stsadm command:

    stsadm –o canceldeployment –id <time job guid>

    To get the time job guid, go to central administration and click operations. Then click the Timer Jobs Definitions link from the Global Configuration panel. After you cancel the deployment job, you can try to remove the solution and add it again globally.



    Kind regards,
    Stanimir
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Back to Top