Deploy problems today

7 posts, 0 answers
  1. David Yardy
    David Yardy avatar
    16 posts
    Member since:
    Aug 2007

    Posted 27 Mar 2013 Link to this post

    Today, I logged in and my project was gone. I started a new one, built and tried to install with the QR code. The QR code navigated me only to the icenium mist web site.

    Is it working? What happened? Inconvenient as this occurred during demonstration.
  2. Jordan
    Admin
    Jordan avatar
    197 posts

    Posted 27 Mar 2013 Link to this post

    Hello David,

    I deeply sorry you have that during presentation I know personally how bad it can be to have issues when presenting something important.

    But as you are first to report this can you help us to reproduce or figure out what went wrong by providing a link from the QR code and the QR Code src value.
     Also are you behind a firewall/gateway/corporate proxy of some sort?
     What is the project name do you have special character or multiple spaces in it?
     What device you deploy on and OS version?

    Kind regards,
    Jordan
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
  3. David Yardy
    David Yardy avatar
    16 posts
    Member since:
    Aug 2007

    Posted 28 Mar 2013 Link to this post

    Couple things that are odd
    I have 2 projects, 
    1.) Tasker (I can access from mist from my laptop, but not my desktop pc).  Right now i am on my desktop and i only see 1 project sample-sqllite 

    2.) The other project sample-sqllite i hooked up to my git repository, but it tells me 'cannot pull into a repository with the state: MERGING'  I can't pull or push to git .  What is the resolution here?

    thanks -dave
  4. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 29 Mar 2013 Link to this post

    Hi David,

    As my colleague pointed out in your other forum thread, both Mist and Graphite would have the same projects as long as you use the same login provider (or the providers have same email associated with them).

    Please start Mist or Graphite and check what email is shown at  the first line of the console log when you open a project. We suspect you have logged from different providers at work (ch2m.com) and at home (e.g. gmail, hotmail).

    About your second issue, open the Version Control menu in Mist and check whether the Conflicts item is enabled. If it is select Conflicts and resolve any pending conflicts. If it is not active, click on History and then click on the Conflicts tab and resolve any that might show there. After all conflicts are resolved, you should be able to push and pull.

    All the best,
    Steve
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
  5. David Yardy
    David Yardy avatar
    16 posts
    Member since:
    Aug 2007

    Posted 29 Mar 2013 Link to this post

    Regarding first issue : they are now seeing the same thing however i seemed to have lost first initial sample project..odd but moving forward.

    2nd Issue... i have sample project sample-sqllite that i am trying to sync/check in with my git repository.  Conflicts wasn't enabled, however when i looked at the history tab, then conflicts i dont see any.

    I have one file that I am trying to commit.  When i try, the console window under says 'unexpected server response: https://app.icenium.com/api/versioncontrol/sample-sqllite:Internal Server error

    Any ideas why the error? (after it says error, i can no longer commit unless i close form and open again to commit again) I have tried a few times.  The date on this was 2013/3/29 15:17:55

    hmm
  6. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 01 Apr 2013 Link to this post

    Hello David,

    Thanks for the clarification and up to your questions:
    1. Nothing is removed from our servers unless you manually delete the project. You are the first person to report such a problem and since we cannot reproduce it, we would appreciate if you provide us with steps to follow (should it happen again).
    2. It is strange that you do not see any conflicting files. Please open the Web Inspector (see Debugging with Mist) and go to the Network Tab. You should see the Internal Server Error there and you can click on it to expand and show the actual stack trace. Please post this stack trace here, so we can inspect it and advise you. In the mean time, we have improved the error handling and for subsequent version of the product would show a dialog with any version control related error.

    On a side note, what happen if you:

    • Copy the contents of the problematic file
    • Delete the file
    • Save all
    • Reload the project and create a new file and use the existing content

    Kind regards,
    Steve
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Kendo UI Dojo.
  7. David Yardy
    David Yardy avatar
    16 posts
    Member since:
    Aug 2007

    Posted 03 Apr 2013 Link to this post

    I removed the repository locally and from git.  To start fresh.  I believe things are reset/better now.
    I will let you know if i experience this issue again (and more detail as to how to reproduce more if possible)
Back to Top