Decompile for Debugging?

3 posts, 0 answers
  1. Steffen
    Steffen avatar
    4 posts
    Member since:
    Apr 2012

    Posted 05 Jul 2013 Link to this post

    Hi,
    i tried to use the Decompile for Debugging Feature. But the debugger never hits the breakpoint.
    "The Breakpoint will not currently be hit. No symbols have been loaded for this document"

    Is use VS2012 - SP3 with JustCode 2013.2.611.6 and JustDecompile 2013.2.613.0. JustTrace, JustMock and Resharper are installed, too.
    Enable just my code and framework source stepping are disabled. I followed this guide: http://www.telerik.com/help/justcode/decompile-for-debugging.html

    Thanks for your help!

    Best regards
    Steffen
  2. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 05 Jul 2013 Link to this post

    Hello Steffen,

     Thanks for contacting us.
    Would you check if you have these paths added to your VS Options window and you find the pdb file of the decompiled assembly in there?

    Did you successfully decompiled the dll that you want to debug? If not, what is the name of the dll? 

    Can you make a sample demo that represents the steps you follow in order to debug? I would recommend Jing tool for this purpose. It is free and offers space for uploading and easy sharing of the videos you make.
    Thanks.

    I look forward to hearing from you.

    Regards,
    Zdravko
    Telerik
    Share what you think about JustCode with us, so we can help you even better! You can use the built-in feedback tool inside JustCode, our forum, or our JustCode feedback portal.
  3. DevCraft banner
  4. Steffen
    Steffen avatar
    4 posts
    Member since:
    Apr 2012

    Posted 05 Jul 2013 Link to this post

    The path to the decompiled sources are in the symbol pathes.

    I installed JustMock 2013.2.701.0 and now it is working fine.
    Perhaps a problem with the Profiler?

    Thanks for your efforts.

    Best regards
    Steffen
Back to Top