Dates not visible on Sunset Skin and Month View

6 posts, 0 answers
  1. David Penny
    David Penny avatar
    174 posts
    Member since:
    Jun 2006

    Posted 09 Sep 2009 Link to this post

    Hi,

    I have just updated to 2009.2.826 and noticed that when the Sunset skin is used, the Month view on my Scheduler does not display any dates (it looks like they are actually set to the same colour as the background).  All other built in skins appear to be OK.

    David Penny.
  2. Veselin Vasilev
    Admin
    Veselin Vasilev avatar
    2992 posts

    Posted 09 Sep 2009 Link to this post

    Hi David Penny,

    I could not reproduce the problem on our online demo. Just select the Sunset skin from the Change Skin dropdown.

    Let me know what is different in your case.

    Sincerely yours,
    Veselin Vasilev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. David Penny
    David Penny avatar
    174 posts
    Member since:
    Jun 2006

    Posted 09 Sep 2009 Link to this post

    Hi,

    The only thing I am doing is to change the apperance of the time blocks so I can control the background colors.

    The following style information is added to the page to accomplish this:

     

     

    <style type="text/css">

     

     

    .RadScheduler .rsAptContent,

     

     

    .RadScheduler .rsAptIn,

     

     

    .RadScheduler .rsAptMid,

     

     

    .RadScheduler .rsAptOut

     

    {

     

    background-image: none !important;

     

    }

     

    </style>

    I have two versions of the application compiled up, one under the 2009 Q1 release and one under the 2009 Q2 release.  The Q1 version shows the dates as expected, the Q2 release version does not, but only on the Sunset Skin

    David Penny

     

  5. Kamen Bundev
    Admin
    Kamen Bundev avatar
    1532 posts

    Posted 11 Sep 2009 Link to this post

    Hello David,

    Looks like this has something to do with a new feature in RadScheduler called Simple appointments. It is switched on automatically when you set background color to an appointment and the image backgrounds are removed. So no need to use the CSS you've mentioned. Can you send a screenshot or a live URL so that we can see what is happening? Thank you in advance.

    Best wishes,
    Kamen Bundev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. Lynda Lafreniere
    Lynda Lafreniere avatar
    33 posts
    Member since:
    Oct 2006

    Posted 09 Nov 2009 Link to this post

    Hi,

    just to mention that the problem is still there and can be observed in your demo here (chose the Sunset skin and chose the Month view).

    I changed it with the css for now, but you shouldn't set white font on white or light gray backgrounds.

    Have a nice day !
  7. Peter
    Admin
    Peter avatar
    6637 posts

    Posted 12 Nov 2009 Link to this post

    Hello folks,

    I was able to observe the problem with the Sunset skin as well. Thank you for reporting this issue and apologies for any inconvenience caused by it. We will fix it for the next service pack.


    Regards,
    Peter
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017